summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorDave Jones <davej@redhat.com>2010-10-26 13:49:21 -0400
committerKyle McMartin <kyle@mcmartin.ca>2010-11-08 11:01:43 -0500
commitb89c80f6e2ff7f1423e676b3cd3604cbe3e54f85 (patch)
tree0020b5b9d14986e137c862b7e3d4a7473041c6b0 /kernel.spec
parentd555d677e1d6aa9b75faf596123508325703c734 (diff)
downloadkernel-b89c80f6e2ff7f1423e676b3cd3604cbe3e54f85.tar.gz
kernel-b89c80f6e2ff7f1423e676b3cd3604cbe3e54f85.tar.xz
kernel-b89c80f6e2ff7f1423e676b3cd3604cbe3e54f85.zip
stop using the obsolete forms of grep shortcuts.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec8
1 files changed, 4 insertions, 4 deletions
diff --git a/kernel.spec b/kernel.spec
index f1be7761a..fcabf99f5 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -917,7 +917,7 @@ ApplyPatch()
exit 1
fi
%if !%{using_upstream_branch}
- if ! egrep "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
+ if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
if [ "${patch:0:10}" != "patch-2.6." ] ; then
echo "ERROR: Patch $patch not listed as a source patch in specfile"
exit 1
@@ -1324,7 +1324,7 @@ for i in *.config
do
mv $i .config
Arch=`head -1 .config | cut -b 3-`
- make ARCH=$Arch listnewconfig | egrep '^CONFIG_' >.newoptions || true
+ make ARCH=$Arch listnewconfig | grep -E '^CONFIG_' >.newoptions || true
%if %{listnewconfig_fail}
if [ -s .newoptions ]; then
cat .newoptions
@@ -1521,7 +1521,7 @@ BuildKernel() {
# Generate a list of modules for block and networking.
- fgrep /drivers/ modnames | xargs --no-run-if-empty nm -upA |
+ grep -F /drivers/ modnames | xargs --no-run-if-empty nm -upA |
sed -n 's,^.*/\([^/]*\.ko\): *U \(.*\)$,\1 \2,p' > drivers.undef
collect_modules_list()
@@ -1547,7 +1547,7 @@ BuildKernel() {
/sbin/modinfo -l $i >> modinfo
done < modnames
- egrep -v \
+ grep -E -v \
'GPL( v2)?$|Dual BSD/GPL$|Dual MPL/GPL$|GPL and additional rights$' \
modinfo && exit 1