summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorDave Jones <davej@redhat.com>2010-10-26 13:43:53 -0400
committerKyle McMartin <kyle@mcmartin.ca>2010-11-08 11:01:13 -0500
commit166b79a5e07606e677a785ab1473979b09bcd95a (patch)
treeaa4a2433026fedc6a2d5739e472423a2c2613453 /kernel.spec
parent3996540995fcf546303547e8ad88c5b2096dce02 (diff)
downloadkernel-166b79a5e07606e677a785ab1473979b09bcd95a.tar.gz
kernel-166b79a5e07606e677a785ab1473979b09bcd95a.tar.xz
kernel-166b79a5e07606e677a785ab1473979b09bcd95a.zip
rpmlint fluff.
kernel.src:386: W: macro-in-comment %nobuildarches kernel.src:432: W: macro-in-comment %post kernel.src:1002: W: macro-in-comment %{vanillaversion} kernel.src:1003: W: macro-in-comment %{kversion} kernel.src:1005: W: macro-in-comment %{kversion} kernel.src:1883: W: macro-in-comment %{image_install_path} (Packagers should avoid using macros in comments, but this is a minor error. The easy fix here is to %% comment out any macros in comments, to prevent unexpected and random behavior.)
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec12
1 files changed, 6 insertions, 6 deletions
diff --git a/kernel.spec b/kernel.spec
index e8450fda7..24a53f3de 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -383,7 +383,7 @@ Summary: The Linux kernel
%endif
# To temporarily exclude an architecture from being built, add it to
-# %nobuildarches. Do _NOT_ use the ExclusiveArch: line, because if we
+# %%nobuildarches. Do _NOT_ use the ExclusiveArch: line, because if we
# don't build kernel-headers then the new build system will no longer let
# us use the previous build of that package -- it'll just be completely AWOL.
# Which is a BadThing(tm).
@@ -429,7 +429,7 @@ Summary: The Linux kernel
%define kernel_headers_conflicts libdrm-devel < 2.4.0-0.15
#
-# Packages that need to be installed before the kernel is, because the %post
+# Packages that need to be installed before the kernel is, because the %%post
# scripts use them.
#
%define kernel_prereq fileutils, module-init-tools, initscripts >= 8.11.1-1, grubby >= 7.0.10-1
@@ -975,10 +975,10 @@ ApplyOptionalPatch()
%endif
%endif
-# %{vanillaversion} : the full version name, e.g. 2.6.35-rc6-git3
-# %{kversion} : the base version, e.g. 2.6.34
+# %%{vanillaversion} : the full version name, e.g. 2.6.35-rc6-git3
+# %%{kversion} : the base version, e.g. 2.6.34
-# Use kernel-%{kversion}%{?dist} as the top-level directory name
+# Use kernel-%%{kversion}%%{?dist} as the top-level directory name
# so we can prep different trees within a single git directory.
# Build a list of the other top-level kernel tree directories.
@@ -1828,7 +1828,7 @@ fi
%{_mandir}/man[1-8]/*
%endif
-# This is %{image_install_path} on an arch where that includes ELF files,
+# This is %%{image_install_path} on an arch where that includes ELF files,
# or empty otherwise.
%define elf_image_install_path %{?kernel_image_elf:%{image_install_path}}