summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorKyle McMartin <kyle@fedoraproject.org>2014-11-17 16:58:58 -0500
committerKyle McMartin <kyle@fedoraproject.org>2014-12-02 10:37:34 -0500
commitd0c82b7f5af913cac8533e7e2dbd2a149eaf42f0 (patch)
tree8c35b19d683248a98ee1c2bfb3805126a0a179ce /kernel.spec
parente955e6d055f63650d023ce8df44aee028ea5a443 (diff)
downloadkernel-d0c82b7f5af913cac8533e7e2dbd2a149eaf42f0.tar.gz
kernel-d0c82b7f5af913cac8533e7e2dbd2a149eaf42f0.tar.xz
kernel-d0c82b7f5af913cac8533e7e2dbd2a149eaf42f0.zip
clean up some debuginfo stuff & python-sitearch
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec30
1 files changed, 16 insertions, 14 deletions
diff --git a/kernel.spec b/kernel.spec
index 6c289c294..500cc1a33 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -376,6 +376,7 @@ Requires: kernel-%{?variant:%{variant}-}modules-uname-r = %{KVERREL}%{?variant}
#
# List the packages used during the kernel build
#
+BuildRequires: python-devel
BuildRequires: kmod, patch, bash, sh-utils, tar
BuildRequires: bzip2, xz, findutils, gzip, m4, perl, perl-Carp, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc
@@ -384,7 +385,7 @@ BuildRequires: net-tools, hostname, bc
BuildRequires: sparse
%endif
%if %{with_perf}
-BuildRequires: elfutils-devel zlib-devel binutils-devel newt-devel python-devel perl(ExtUtils::Embed) bison flex
+BuildRequires: elfutils-devel zlib-devel binutils-devel newt-devel perl(ExtUtils::Embed) bison flex
BuildRequires: audit-libs-devel
%ifnarch s390 s390x %{arm}
BuildRequires: numactl-devel
@@ -396,7 +397,8 @@ BuildRequires: pciutils-devel gettext ncurses-devel
BuildConflicts: rhbuildsys(DiskFree) < 500Mb
%if %{with_debuginfo}
BuildRequires: rpm-build, elfutils
-%define debuginfo_args --strict-build-id -r
+%define _missing_build_ids_terminate_build 1
+%global _find_debuginfo_opts -r
%endif
%if %{signmodules}
@@ -697,7 +699,7 @@ This package provides debug information for the perf package.
# symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file.
-%{expand:%%global debuginfo_args %{?debuginfo_args} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|.*%%{_libdir}/traceevent/plugins/.*|XXX' -o perf-debuginfo.list}
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|.*%%{_libdir}/traceevent/plugins/.*|XXX' -o perf-debuginfo.list}
%package -n python-perf
Summary: Python bindings for apps which will manipulate perf events
@@ -707,8 +709,6 @@ The python-perf package contains a module that permits applications
written in the Python programming language to use the interface
to manipulate perf events.
-%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
-
%package -n python-perf-debuginfo
Summary: Debug information for package perf python bindings
Group: Development/Debug
@@ -717,8 +717,8 @@ AutoReqProv: no
%description -n python-perf-debuginfo
This package provides debug information for the perf python bindings.
-# the python_sitearch macro should already be defined from above
-%{expand:%%global debuginfo_args %{?debuginfo_args} -p '.*%%{python_sitearch}/perf.so(\.debug)?|XXX' -o python-perf-debuginfo.list}
+%define __python_sitearch %%{python_sitearch}
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_libdir}/python*/site-packages/perf.so(\.debug)?|XXX' -o python-perf-debuginfo.list}
%endif # with_perf
@@ -773,7 +773,7 @@ This package provides debug information for package kernel-tools.
# symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file.
-%{expand:%%global debuginfo_args %{?debuginfo_args} -p '.*%%{_bindir}/centrino-decode(\.debug)?|.*%%{_bindir}/powernow-k8-decode(\.debug)?|.*%%{_bindir}/cpupower(\.debug)?|.*%%{_libdir}/libcpupower.*|.*%%{_bindir}/turbostat(\.debug)?|.*%%{_bindir}/x86_energy_perf_policy(\.debug)?|.*%%{_bindir}/tmon(\.debug)?|XXX' -o kernel-tools-debuginfo.list}
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_bindir}/centrino-decode(\.debug)?|.*%%{_bindir}/powernow-k8-decode(\.debug)?|.*%%{_bindir}/cpupower(\.debug)?|.*%%{_libdir}/libcpupower.*|.*%%{_bindir}/turbostat(\.debug)?|.*%%{_bindir}/x86_energy_perf_policy(\.debug)?|.*%%{_bindir}/tmon(\.debug)?|XXX' -o kernel-tools-debuginfo.list}
%endif # with_tools
@@ -792,7 +792,7 @@ AutoReqProv: no\
%description -n %{name}%{?1:-%{1}}-debuginfo\
This package provides debug information for package %{name}%{?1:-%{1}}.\
This is required to use SystemTap with %{name}%{?1:-%{1}}-%{KVERREL}.\
-%{expand:%%global debuginfo_args %{?debuginfo_args} -p '/.*/%%{KVERREL}%{?1:[+]%{1}}/.*|/.*%%{KVERREL}%{?1:\+%{1}}(\.debug)?' -o debuginfo%{?1}.list}\
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '/.*/%%{KVERREL}%{?1:[+]%{1}}/.*|/.*%%{KVERREL}%{?1:\+%{1}}(\.debug)?' -o debuginfo%{?1}.list}\
%{nil}
#
@@ -1823,10 +1823,6 @@ popd
%if %{with_debuginfo}
-%define __debug_install_post \
- /usr/lib/rpm/find-debuginfo.sh %{debuginfo_args} %{_builddir}/%{?buildsubdir}\
-%{nil}
-
%ifnarch noarch
%global __debug_package 1
%files -f debugfiles.list debuginfo-common-%{_target_cpu}
@@ -2074,7 +2070,7 @@ fi
%files -n python-perf
%defattr(-,root,root)
-%{python_sitearch}
+%{__python_sitearch}
%if %{with_debuginfo}
%files -f perf-debuginfo.list -n perf-debuginfo
@@ -2201,6 +2197,12 @@ fi
# ||----w |
# || ||
%changelog
+* Tue Dec 02 2014 Kyle McMartin <kyle@fedoraproject.org>
+- python-devel is BuildRequires regardless of with_perf.
+- Use %_find_debuginfo_opts instead of pointless debuginfo_args.
+- Remove pointless __debug_install_post.
+- Remove python_sitearch since it's in the global rpm macros anyway.
+
* Mon Dec 01 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.18.0-0.rc7.git0.1
- Linux v3.18-rc7