summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@fedoraproject.org>2014-09-02 12:42:53 -0400
committerJosh Boyer <jwboyer@fedoraproject.org>2014-09-02 12:42:58 -0400
commit219cc0ba424b7df1805da2dc088b3024662039fe (patch)
tree82c551f944d323bb76c2a4c5a655329583a1b73e /kernel.spec
parent27d7c4756aae270c7f272675f73e63644c927582 (diff)
downloadkernel-219cc0ba424b7df1805da2dc088b3024662039fe.tar.gz
kernel-219cc0ba424b7df1805da2dc088b3024662039fe.tar.xz
kernel-219cc0ba424b7df1805da2dc088b3024662039fe.zip
Remove with_extra switch
The with_extra switch was originally added with the addition of the modules-extra subpackage. However, it never really worked. If you build with it disabled, the subpackage is omitted but the modules that would be included in it would still be built. That can lead to errors further in the build when we're moving things around in the -core and -modules subpackages. Since it doesn't actually save build time at all, and it leads to build failures for no real gain, drop it.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec13
1 files changed, 3 insertions, 10 deletions
diff --git a/kernel.spec b/kernel.spec
index d048a6249..bdf1a1ce3 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -94,8 +94,6 @@ Summary: The Linux kernel
%define with_debug %{?_without_debug: 0} %{?!_without_debug: 1}
# kernel-headers
%define with_headers %{?_without_headers: 0} %{?!_without_headers: 1}
-# kernel-modules-extra
-%define with_extra %{?_without_extra: 0} %{?!_without_extra: 1}
# perf
%define with_perf %{?_without_perf: 0} %{?!_without_perf: 1}
# tools
@@ -925,9 +923,7 @@ Provides: kernel-%{?1:%{1}-}core-uname-r = %{KVERREL}%{?1:+%{1}}\
%endif\
%{expand:%%kernel_devel_package %{?1:%{1}} %{!?{-n}:%{1}}%{?{-n}:%{-n*}}}\
%{expand:%%kernel_modules_package %{?1:%{1}} %{!?{-n}:%{1}}%{?{-n}:%{-n*}}}\
-%if %{with_extra}\
%{expand:%%kernel_modules_extra_package %{?1:%{1}} %{!?{-n}:%{1}}%{?{-n}:%{-n*}}}\
-%endif\
%{expand:%%kernel_debuginfo_package %{?1:%{1}}}\
%{nil}
@@ -1694,10 +1690,8 @@ BuildKernel() {
rm -f modules.{alias*,builtin.bin,dep*,*map,symbols*,devname,softdep}
popd
-%if %{with_extra}
# Call the modules-extra script to move things around
%{SOURCE17} $RPM_BUILD_ROOT/lib/modules/$KernelVer %{SOURCE16}
-%endif
#
# Generate the kernel-core and kernel-modules files lists
@@ -2067,9 +2061,7 @@ fi\
%define kernel_variant_post(v:r:) \
%{expand:%%kernel_devel_post %{?-v*}}\
%{expand:%%kernel_modules_post %{?-v*}}\
-%if %{with_extra}\
%{expand:%%kernel_modules_extra_post %{?-v*}}\
-%endif\
%{expand:%%kernel_variant_posttrans %{?-v*}}\
%{expand:%%post %{?-v*:%{-v*}-}core}\
%{-r:\
@@ -2230,9 +2222,7 @@ fi
%{expand:%%files %{?2:%{2}-}devel}\
%defattr(-,root,root)\
/usr/src/kernels/%{KVERREL}%{?2:+%{2}}\
-%if %{with_extra}\
%{expand:%%files %{?2:%{2}-}modules-extra}\
-%endif\
%defattr(-,root,root)\
/lib/modules/%{KVERREL}%{?2:+%{2}}/extra\
%if %{with_debuginfo}\
@@ -2269,6 +2259,9 @@ fi
# ||----w |
# || ||
%changelog
+* Tue Sep 02 2014 Josh Boyer <jwboyer@fedoraproject.org>
+- Remove with_extra switch
+
* Mon Sep 01 2014 Josh Boyer <jwboyer@fedoraproject.org> - 3.17.0-0.rc3.git0.1
- Linux v3.17-rc3
- Disable debugging options.