summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorDave Jones <davej@redhat.com>2012-04-02 17:54:24 -0400
committerDave Jones <davej@redhat.com>2012-04-02 17:54:24 -0400
commit30514337d11a65361c9e1e1f153d060f32aae138 (patch)
tree1194458f4a03dcad236d57004b767600093e1916 /kernel.spec
parent3e716334ce7c3d281567e000642a28886971b251 (diff)
downloadkernel-30514337d11a65361c9e1e1f153d060f32aae138.tar.gz
kernel-30514337d11a65361c9e1e1f153d060f32aae138.tar.xz
kernel-30514337d11a65361c9e1e1f153d060f32aae138.zip
Skip config entirely when noarch
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec24
1 files changed, 10 insertions, 14 deletions
diff --git a/kernel.spec b/kernel.spec
index 339f2b57a..034c4dc08 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -1457,21 +1457,17 @@ done
rm -f kernel-%{version}-*debug.config
%endif
-arch=%{_target_cpu}
-# Koji preps as noarch. Pick the config file for the arch.
-if [ "%{_target_cpu}" -eq "noarch" ]; then
- arch=$(uname -p)
+# run oldconfig over the config files (except when noarch)
+if [ "%{_target_cpu}" != "noarch" ]; then
+ for i in kernel-*-%{_target_cpu}-*.config
+ do
+ mv $i .config
+ Arch=`head -1 .config | cut -b 3-`
+ make ARCH=$Arch oldnoconfig
+ echo "# $Arch" > configs/$i
+ cat .config >> configs/$i
+ done
fi
-
-# now run oldconfig over the config files
-for i in kernel-*-$arch-*.config
-do
- mv $i .config
- Arch=`head -1 .config | cut -b 3-`
- make ARCH=$Arch oldnoconfig
- echo "# $Arch" > configs/$i
- cat .config >> configs/$i
-done
# end of kernel config
%endif