summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2019-11-13 22:30:41 +0100
committerThorsten Leemhuis <fedora@leemhuis.info>2019-11-13 22:30:41 +0100
commitfd88376bf7787f6734a6dca48e6986b915e17669 (patch)
tree1dfd06e7d35a01b2c254d8289a68eaf77688e93a /kernel.spec
parenta6ba1b6c1d4a33765b25e064183494d1cf4dadab (diff)
parent6f0f15962eb202999219edb2fd50efa8199d8bd2 (diff)
downloadkernel-fd88376bf7787f6734a6dca48e6986b915e17669.tar.gz
kernel-fd88376bf7787f6734a6dca48e6986b915e17669.tar.xz
kernel-fd88376bf7787f6734a6dca48e6986b915e17669.zip
Merge remote-tracking branch 'origin/master' into rawhide-user-thl-vanilla-fedorakernel-5.4.0-0.rc7.git1.1.vanilla.knurd.1.fc31
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec33
1 files changed, 17 insertions, 16 deletions
diff --git a/kernel.spec b/kernel.spec
index e5a046e1f..7670c36f2 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -108,7 +108,7 @@ Summary: The Linux kernel
# The rc snapshot level
%global rcrev 7
# The git snapshot level
-%define gitrev 0
+%define gitrev 1
# Set rpm version accordingly
%define rpmversion 5.%{upstream_sublevel}.0
%endif
@@ -154,7 +154,7 @@ Summary: The Linux kernel
# Only build the debug kernel (--with dbgonly):
%define with_dbgonly %{?_with_dbgonly: 1} %{?!_with_dbgonly: 0}
# Control whether we perform a compat. check against published ABI.
-#%define with_kabichk %{?_without_kabichk: 0} %{?!_without_kabichk: 1}
+%define with_kabichk %{?_without_kabichk: 0} %{?!_without_kabichk: 1}
# Temporarily disable kabi checks until RC.
%define with_kabichk 0
# Control whether we perform a compat. check against DUP ABI.
@@ -195,7 +195,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 1
+%define debugbuildsenabled 0
%if 0%{?fedora}
# Kernel headers are being split out into a separate package
@@ -812,7 +812,6 @@ This package is required by %{name}-debuginfo subpackages.
It provides the kernel source files common to all builds.
%if %{with_selftests}
-
%package selftests-internal
Summary: Kernel samples and selftests
License: GPLv2
@@ -820,14 +819,13 @@ Requires: binutils, bpftool, iproute-tc, nmap-ncat
Requires: kernel-modules-internal = %{version}-%{release}
%description selftests-internal
Kernel sample programs and selftests.
-
+%{nil}
# Note that this pattern only works right to match the .build-id
# symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file.
%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_libexecdir}/(ksamples|kselftests)/.*|XXX' -o selftests-debuginfo.list}
-
-%endif # with_selftests
+%endif
%if %{with_gcov}
%package gcov
@@ -1017,7 +1015,7 @@ Cortex-A15 devices with LPAE and HW virtualisation support
%description zfcpdump-core
The kernel package contains the Linux kernel (vmlinuz) for use by the
zfcpdump infrastructure.
-%endif # with_zfcpdump
+%endif
%define variant_summary The Linux kernel compiled with extra debugging enabled
%kernel_variant_package debug
@@ -1447,9 +1445,7 @@ BuildKernel() {
%endif
# make sure EXTRAVERSION says what we want it to say
- # Trim the release if this is a CI build, since KERNELVERSION is limited to 64 characters
- ShortRel=$(perl -e "print \"%{release}\" =~ s/\.pr\.[0-9A-Fa-f]{32}//r")
- perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -${ShortRel}.%{_target_cpu}${Flav}/" Makefile
+ perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}.%{_target_cpu}${Flav}/" Makefile
# if pre-rc1 devel kernel, must fix up PATCHLEVEL for our versioning scheme
%if !0%{?rcrev}
@@ -1533,8 +1529,8 @@ BuildKernel() {
%pesign -s -i $KernelImage -o vmlinuz.signed
%else
%pesign -s -i $SignImage -o vmlinuz.signed -a %{secureboot_ca} -c %{secureboot_key} -n %{pesign_name}
- %endif # fedora
- %endif # arches
+ %endif
+ %endif
%ifarch s390x ppc64le
if [ -x /usr/bin/rpm-sign ]; then
rpm-sign --key "%{pesign_name}" --lkmsign $SignImage --output vmlinuz.signed
@@ -2076,7 +2072,7 @@ docdir=$RPM_BUILD_ROOT%{_datadir}/doc/kernel-doc-%{rpmversion}
mkdir -p $docdir
tar -h -f - --exclude=man --exclude='.*' -c Documentation | tar xf - -C $docdir
-%endif # with_doc
+%endif
# We have to do the headers install before the tools install because the
# kernel headers_install will remove any header files in /usr/include that
@@ -2118,10 +2114,9 @@ rm -rf $RPM_BUILD_ROOT/usr/tmp-headers
# kabi directory
INSTALL_KABI_PATH=$RPM_BUILD_ROOT/lib/modules/
mkdir -p $INSTALL_KABI_PATH
-
# install kabi releases directories
tar xjvf %{SOURCE300} -C $INSTALL_KABI_PATH
-%endif # with_kernel_abi_whitelists
+%endif
%if %{with_selftests}
pushd samples
@@ -2433,6 +2428,12 @@ fi
#
#
%changelog
+* Wed Nov 13 2019 Jeremy Cline <jcline@redhat.com> - 5.4.0-0.rc7.git1.1
+- Linux v5.4-rc7-49-g0e3f1ad80fc8
+
+* Wed Nov 13 2019 Jeremy Cline <jcline@redhat.com>
+- Reenable debugging options.
+
* Mon Nov 11 2019 Jeremy Cline <jcline@redhat.com> - 5.4.0-0.rc7.git0.1
- Linux v5.4-rc7