summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2019-09-06 16:36:31 +0200
committerThorsten Leemhuis <fedora@leemhuis.info>2019-09-06 16:36:31 +0200
commit532dcda3f56a7938e96558d7b1f0fa219c57fc01 (patch)
treec2e936cb072cd8b02351eae16b2172dfc147fb1d /kernel.spec
parent563159937d0950f5e18f3ff89f2aa3faad215bf1 (diff)
parentbff345a8a89e4b15bbaf758cc8e787431dd0270e (diff)
downloadkernel-532dcda3f56a7938e96558d7b1f0fa219c57fc01.tar.gz
kernel-532dcda3f56a7938e96558d7b1f0fa219c57fc01.tar.xz
kernel-532dcda3f56a7938e96558d7b1f0fa219c57fc01.zip
merge master
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec60
1 files changed, 21 insertions, 39 deletions
diff --git a/kernel.spec b/kernel.spec
index e4a1464f7..885179c71 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -79,7 +79,7 @@ Summary: The Linux kernel
# The rc snapshot level
%global rcrev 7
# The git snapshot level
-%define gitrev 0
+%define gitrev 1
# Set rpm version accordingly
%define rpmversion 5.%{upstream_sublevel}.0
%endif
@@ -575,8 +575,14 @@ Patch306: arm-sdhci-esdhc-imx-fixes.patch
Patch320: arm64-tegra-jetson-tx1-fixes.patch
# https://www.spinics.net/lists/linux-tegra/msg43110.html
Patch321: arm64-tegra-Jetson-TX2-Allow-bootloader-to-configure.patch
-# https://patchwork.kernel.org/patch/11084925/
-Patch322: arm64-Revert-mmc-sdhci-tegra-drop---get_ro-implementation.patch
+
+# QCom laptop bits
+# https://patchwork.kernel.org/patch/11133827/
+Patch330: arm64-qcom-i2c-geni-Disable-DMA-processing-on-the-Lenovo-Yoga-C630.patch
+# https://patchwork.kernel.org/patch/11127947/
+Patch331: arm64-qcom-soc-geni-Provide-parameter-error-checking.patch
+# https://patchwork.kernel.org/patch/11133293/
+Patch332: arm64-dts-qcom-Add-Lenovo-Yoga-C630.patch
# 400 - IBM (ppc/s390x) patches
@@ -828,42 +834,6 @@ if [ "%{patches}" != "%%{patches}" ] ; then
done
fi 2>/dev/null
-patch_command='patch -p1 -F1 -s'
-ApplyPatch()
-{
- local patch=$1
- shift
- if [ ! -f $RPM_SOURCE_DIR/$patch ]; then
- exit 1
- fi
- if ! grep -E "^Patch[0-9]+: $patch\$" %{_specdir}/${RPM_PACKAGE_NAME%%%%%{?variant}}.spec ; then
- if [ "${patch:0:8}" != "patch-5." ] ; then
- echo "ERROR: Patch $patch not listed as a source patch in specfile"
- exit 1
- fi
- fi 2>/dev/null
- case "$patch" in
- *.bz2) bunzip2 < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
- *.gz) gunzip < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
- *.xz) unxz < "$RPM_SOURCE_DIR/$patch" | $patch_command ${1+"$@"} ;;
- *) $patch_command ${1+"$@"} < "$RPM_SOURCE_DIR/$patch" ;;
- esac
-}
-
-# don't apply patch if it's empty
-ApplyOptionalPatch()
-{
- local patch=$1
- shift
- if [ ! -f $RPM_SOURCE_DIR/$patch ]; then
- exit 1
- fi
- local C=$(wc -l $RPM_SOURCE_DIR/$patch | awk '{print $1}')
- if [ "$C" -gt 9 ]; then
- ApplyPatch $patch ${1+"$@"}
- fi
-}
-
# First we unpack the kernel tarball.
# If this isn't the first make prep, we use links to the existing clean tarball
# which speeds things up quite a bit.
@@ -1831,6 +1801,18 @@ fi
#
#
%changelog
+* Thu Sep 05 2019 Laura Abbott <labbott@redhat.com> - 5.3.0-0.rc7.git1.1
+- Linux v5.3-rc7-2-g3b47fd5ca9ea
+
+* Thu Sep 05 2019 Laura Abbott <labbott@redhat.com>
+- Reenable debugging options.
+
+* Tue Sep 03 2019 Laura Abbott <labbott@redhat.com> - 5.3.0-0.rc7.git0.1
+- Linux v5.3-rc7
+
+* Tue Sep 03 2019 Laura Abbott <labbott@redhat.com>
+- Disable debugging options.
+
* Thu Aug 29 2019 Laura Abbott <labbott@redhat.com> - 5.3.0-0.rc6.git2.1
- Linux v5.3-rc6-119-g9cf6b756cdf2