summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorPeter Robinson <pbrobinson@gmail.com>2013-01-27 16:17:49 +0000
committerPeter Robinson <pbrobinson@gmail.com>2013-01-27 16:17:49 +0000
commit783eee9cbffe40235194839151a520a0510ea1aa (patch)
tree911a7bed5c844394f5d856d7f7f5914a94484f58 /kernel.spec
parentd0a8cf569b30a0a9318aa47d59405efe5afb519a (diff)
downloadkernel-783eee9cbffe40235194839151a520a0510ea1aa.tar.gz
kernel-783eee9cbffe40235194839151a520a0510ea1aa.tar.xz
kernel-783eee9cbffe40235194839151a520a0510ea1aa.zip
Reenable perf on ARM (was suppose to be temporary), Build and package dtbs on ARM
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/kernel.spec b/kernel.spec
index 935f11908..38688b779 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -402,8 +402,6 @@ Summary: The Linux kernel
%define with_perf 0
%define with_tools 0
%endif
-# TEMPORARY until perf build fixed on ARM to get a new 3.7rc kernel
-%define with_perf 0
%endif
# Should make listnewconfig fail if there's config options
@@ -1581,6 +1579,10 @@ BuildKernel() {
%ifarch %{arm}
# http://lists.infradead.org/pipermail/linux-arm-kernel/2012-March/091404.html
make -s ARCH=$Arch V=1 %{?_smp_mflags} $MakeTarget %{?sparse_mflags} KALLSYMS_EXTRA_PASS=1
+
+ make -s ARCH=$Arch V=1 dtbs
+ mkdir -p $RPM_BUILD_ROOT/%{image_install_path}/dtb-$KernelVer
+ install -m 644 arch/arm/boot/dts/*.dtb $RPM_BUILD_ROOT/boot/dtb-$KernelVer/
%else
make -s ARCH=$Arch V=1 %{?_smp_mflags} $MakeTarget %{?sparse_mflags}
%endif
@@ -2258,6 +2260,9 @@ fi
%defattr(-,root,root)\
/%{image_install_path}/%{?-k:%{-k*}}%{!?-k:vmlinuz}-%{KVERREL}%{?2:.%{2}}\
/%{image_install_path}/.vmlinuz-%{KVERREL}%{?2:.%{2}}.hmac \
+%ifarch %{arm}\
+/%{image_install_path}/dtb-%{KVERREL}%{?2:.%{2}} \
+%endif\
%attr(600,root,root) /boot/System.map-%{KVERREL}%{?2:.%{2}}\
/boot/config-%{KVERREL}%{?2:.%{2}}\
%dir /lib/modules/%{KVERREL}%{?2:.%{2}}\
@@ -2309,6 +2314,10 @@ fi
# ||----w |
# || ||
%changelog
+* Sun Jan 27 2013 Peter Robinson <pbrobinson@fedoraproject.org>
+- Reenable perf on ARM (was suppose to be temporary)
+- Build and package dtbs on ARM
+
* Fri Jan 25 2013 Kyle McMartin <kmcmarti@redhat.com>
- Sign all modules with the mod-extra-sign.sh script, ensures nothing gets
missed because of .config differences between invocations of BuildKernel.