summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJustin M. Forbes <jforbes@fedoraproject.org>2021-05-26 15:24:34 -0500
committerJustin M. Forbes <jforbes@fedoraproject.org>2021-05-26 15:24:34 -0500
commit005d54b78b320d32a78d54b9e40748672a5e703b (patch)
treea10979af2b2cc4e2a0e7c2b0c1a166129de3f329 /kernel.spec
parent7704c4a937d260d4d971232d2aef4b9893fb4601 (diff)
downloadkernel-005d54b78b320d32a78d54b9e40748672a5e703b.tar.gz
kernel-005d54b78b320d32a78d54b9e40748672a5e703b.tar.xz
kernel-005d54b78b320d32a78d54b9e40748672a5e703b.zip
kernel-5.13.0-0.rc3.20210526gitad9f25d33860.27
* Wed May 26 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc3.20210526gitad9f25d33860.27] - team: mark team driver as deprecated (Hangbin Liu) [1945477] Resolves: rhbz#1945477 Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec25
1 files changed, 14 insertions, 11 deletions
diff --git a/kernel.spec b/kernel.spec
index 154daf2d2..20b1488fb 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -73,7 +73,7 @@ Summary: The Linux kernel
# the --with-release option overrides this setting.)
%define debugbuildsenabled 0
-%global distro_build 0.rc3.20210525gita050a6d2b7e8.26
+%global distro_build 0.rc3.20210526gitad9f25d33860.27
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -117,13 +117,13 @@ Summary: The Linux kernel
%define kversion 5.13
%define rpmversion 5.13.0
-%define pkgrelease 0.rc3.20210525gita050a6d2b7e8.26
+%define pkgrelease 0.rc3.20210526gitad9f25d33860.27
# This is needed to do merge window version magic
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc3.20210525gita050a6d2b7e8.26%{?buildid}%{?dist}
+%define specrelease 0.rc3.20210526gitad9f25d33860.27%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -546,6 +546,7 @@ BuildRequires: audit-libs-devel
BuildRequires: java-devel
BuildRequires: libbpf-devel
BuildRequires: libbabeltrace-devel
+BuildRequires: libtraceevent-devel
%ifnarch %{arm} s390x
BuildRequires: numactl-devel
%endif
@@ -623,7 +624,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.13-rc3-39-ga050a6d2b7e8.tar.xz
+Source0: linux-5.13-rc3-43-gad9f25d33860.tar.xz
Source1: Makefile.rhelver
@@ -875,7 +876,7 @@ This package provides debug information for the perf package.
# symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file.
-%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|.*%%{_libdir}/traceevent/plugins/.*|.*%%{_libdir}/libperf-jvmti.so(\.debug)?|XXX' -o perf-debuginfo.list}
+%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_bindir}/perf(\.debug)?|.*%%{_libexecdir}/perf-core/.*|.*%%{_libdir}/libperf-jvmti.so(\.debug)?|XXX' -o perf-debuginfo.list}
%package -n python3-perf
Summary: Python bindings for apps which will manipulate perf events
@@ -1292,8 +1293,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.13-rc3-39-ga050a6d2b7e8 -c
-mv linux-5.13-rc3-39-ga050a6d2b7e8 linux-%{KVERREL}
+%setup -q -n kernel-5.13-rc3-43-gad9f25d33860 -c
+mv linux-5.13-rc3-43-gad9f25d33860 linux-%{KVERREL}
cd linux-%{KVERREL}
cp -a %{SOURCE1} .
@@ -2073,7 +2074,7 @@ InitBuildVars
%endif
%global perf_make \
- %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 prefix=%{_prefix} PYTHON=%{__python3}
+ %{__make} %{?make_opts} EXTRA_CFLAGS="${RPM_OPT_FLAGS}" LDFLAGS="%{__global_ldflags}" %{?cross_opts} -C tools/perf V=1 NO_PERF_READ_VDSO32=1 NO_PERF_READ_VDSOX32=1 WERROR=0 NO_LIBUNWIND=1 HAVE_CPLUS_DEMANGLE=1 NO_GTK2=1 NO_STRLCPY=1 NO_BIONIC=1 LIBBPF_DYNAMIC=1 LIBTRACEEVENT_DYNAMIC=1 prefix=%{_prefix} PYTHON=%{__python3}
%if %{with_perf}
# perf
# make sure check-headers.sh is executable
@@ -2286,7 +2287,7 @@ tar xjvf %{SOURCE300} -C $INSTALL_KABI_PATH
%if %{with_perf}
# perf tool binary and supporting scripts/binaries
-%{perf_make} DESTDIR=$RPM_BUILD_ROOT lib=%{_lib} install-bin install-traceevent-plugins
+%{perf_make} DESTDIR=$RPM_BUILD_ROOT lib=%{_lib} install-bin
# remove the 'trace' symlink.
rm -f %{buildroot}%{_bindir}/trace
@@ -2594,8 +2595,7 @@ fi
%files -n perf
%{_bindir}/perf
%{_libdir}/libperf-jvmti.so
-%dir %{_libdir}/traceevent/plugins
-%{_libdir}/traceevent/plugins/*
+%exclude %{_libdir}/traceevent
%dir %{_libexecdir}/perf-core
%{_libexecdir}/perf-core/*
%{_datadir}/perf-core/*
@@ -2795,6 +2795,9 @@ fi
#
#
%changelog
+* Wed May 26 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc3.20210526gitad9f25d33860.27]
+- team: mark team driver as deprecated (Hangbin Liu) [1945477]
+
* Tue May 25 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc3.20210525gita050a6d2b7e8.26]
- Make CRYPTO_EC also builtin (Simo Sorce) [1947240]
- Do not hard-code a default value for DIST (David Ward)