summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorLaura Abbott <labbott@fedoraproject.org>2019-11-11 21:01:25 +0000
committerLaura Abbott <labbott@fedoraproject.org>2019-11-11 21:01:25 +0000
commit4df513d076c6f4c9528c40e2a61948fbab2932ef (patch)
treed23d1566585a684bce5a4bbe987a9921d2ff6b5c /kernel.spec
parent2147ca93975deaf220619e9096e0b84d879febc9 (diff)
parentd753bc001a2a92bc325ccaca10497c7e2049f6ff (diff)
downloadkernel-4df513d076c6f4c9528c40e2a61948fbab2932ef.tar.gz
kernel-4df513d076c6f4c9528c40e2a61948fbab2932ef.tar.xz
kernel-4df513d076c6f4c9528c40e2a61948fbab2932ef.zip
Merge #39 `Fix existing CI test and resolve syntax warnings`
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec23
1 files changed, 9 insertions, 14 deletions
diff --git a/kernel.spec b/kernel.spec
index 23dd10edf..a44ac8ae0 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -146,7 +146,7 @@ Summary: The Linux kernel
# Only build the debug kernel (--with dbgonly):
%define with_dbgonly %{?_with_dbgonly: 1} %{?!_with_dbgonly: 0}
# Control whether we perform a compat. check against published ABI.
-#%define with_kabichk %{?_without_kabichk: 0} %{?!_without_kabichk: 1}
+%define with_kabichk %{?_without_kabichk: 0} %{?!_without_kabichk: 1}
# Temporarily disable kabi checks until RC.
%define with_kabichk 0
# Control whether we perform a compat. check against DUP ABI.
@@ -795,7 +795,6 @@ This package is required by %{name}-debuginfo subpackages.
It provides the kernel source files common to all builds.
%if %{with_selftests}
-
%package selftests-internal
Summary: Kernel samples and selftests
License: GPLv2
@@ -803,14 +802,13 @@ Requires: binutils, bpftool, iproute-tc, nmap-ncat
Requires: kernel-modules-internal = %{version}-%{release}
%description selftests-internal
Kernel sample programs and selftests.
-
+%{nil}
# Note that this pattern only works right to match the .build-id
# symlinks because of the trailing nonmatching alternation and
# the leading .*, because of find-debuginfo.sh's buggy handling
# of matching the pattern against the symlinks file.
%{expand:%%global _find_debuginfo_opts %{?_find_debuginfo_opts} -p '.*%%{_libexecdir}/(ksamples|kselftests)/.*|XXX' -o selftests-debuginfo.list}
-
-%endif # with_selftests
+%endif
%if %{with_gcov}
%package gcov
@@ -1000,7 +998,7 @@ Cortex-A15 devices with LPAE and HW virtualisation support
%description zfcpdump-core
The kernel package contains the Linux kernel (vmlinuz) for use by the
zfcpdump infrastructure.
-%endif # with_zfcpdump
+%endif
%define variant_summary The Linux kernel compiled with extra debugging enabled
%kernel_variant_package debug
@@ -1427,9 +1425,7 @@ BuildKernel() {
%endif
# make sure EXTRAVERSION says what we want it to say
- # Trim the release if this is a CI build, since KERNELVERSION is limited to 64 characters
- ShortRel=$(perl -e "print \"%{release}\" =~ s/\.pr\.[0-9A-Fa-f]{32}//r")
- perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -${ShortRel}.%{_target_cpu}${Flav}/" Makefile
+ perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}.%{_target_cpu}${Flav}/" Makefile
# if pre-rc1 devel kernel, must fix up PATCHLEVEL for our versioning scheme
%if !0%{?rcrev}
@@ -1513,8 +1509,8 @@ BuildKernel() {
%pesign -s -i $KernelImage -o vmlinuz.signed
%else
%pesign -s -i $SignImage -o vmlinuz.signed -a %{secureboot_ca} -c %{secureboot_key} -n %{pesign_name}
- %endif # fedora
- %endif # arches
+ %endif
+ %endif
%ifarch s390x ppc64le
if [ -x /usr/bin/rpm-sign ]; then
rpm-sign --key "%{pesign_name}" --lkmsign $SignImage --output vmlinuz.signed
@@ -2056,7 +2052,7 @@ docdir=$RPM_BUILD_ROOT%{_datadir}/doc/kernel-doc-%{rpmversion}
mkdir -p $docdir
tar -h -f - --exclude=man --exclude='.*' -c Documentation | tar xf - -C $docdir
-%endif # with_doc
+%endif
# We have to do the headers install before the tools install because the
# kernel headers_install will remove any header files in /usr/include that
@@ -2098,10 +2094,9 @@ rm -rf $RPM_BUILD_ROOT/usr/tmp-headers
# kabi directory
INSTALL_KABI_PATH=$RPM_BUILD_ROOT/lib/modules/
mkdir -p $INSTALL_KABI_PATH
-
# install kabi releases directories
tar xjvf %{SOURCE300} -C $INSTALL_KABI_PATH
-%endif # with_kernel_abi_whitelists
+%endif
%if %{with_selftests}
pushd samples