summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2021-05-11 04:59:26 +0200
committerThorsten Leemhuis <fedora@leemhuis.info>2021-05-11 04:59:26 +0200
commit4175ff4c06a210cc0d4982fa271a45dc601c2a48 (patch)
tree19cce4d729e455ed8e89ff149b22ab73d1e61ccb /kernel.spec
parentedd23aa5290134f56d57c87a689e8002a8b23274 (diff)
parent1cac231319309a8322c7f29d89644752aba75a62 (diff)
downloadkernel-4175ff4c06a210cc0d4982fa271a45dc601c2a48.tar.gz
kernel-4175ff4c06a210cc0d4982fa271a45dc601c2a48.tar.xz
kernel-4175ff4c06a210cc0d4982fa271a45dc601c2a48.zip
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec56
1 files changed, 43 insertions, 13 deletions
diff --git a/kernel.spec b/kernel.spec
index 8bfcb6009..c4bc54ec7 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -66,7 +66,7 @@ Summary: The Linux kernel
# For a stable, released kernel, released_kernel should be 1.
%global released_kernel 0
-%global distro_build 0.rc0.20210504git5e321ded302d.7
+%global distro_build 0.rc1.13
%if 0%{?fedora}
%define secure_boot_arch x86_64
@@ -109,13 +109,13 @@ Summary: The Linux kernel
%endif
%define rpmversion 5.13.0
-%define pkgrelease 0.rc0.20210504git5e321ded302d.7
+%define pkgrelease 0.rc1.13
# This is needed to do merge window version magic
%define patchlevel 13
# allow pkg_release to have configurable %%{?dist} tag
-%define specrelease 0.rc0.20210504git5e321ded302d.7%{?buildid}%{?dist}
+%define specrelease 0.rc1.13%{?buildid}%{?dist}
%define pkg_release %{specrelease}
@@ -620,7 +620,7 @@ BuildRequires: clang
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.12-13670-g5e321ded302d.tar.xz
+Source0: linux-5.13-rc1.tar.xz
Source1: Makefile.rhelver
@@ -733,7 +733,6 @@ Source50: kernel-x86_64-debug-fedora.config
Source51: generate_all_configs.sh
Source52: process_configs.sh
-Source53: generate_bls_conf.sh
Source56: update_scripts.sh
Source54: mod-internal.list
@@ -768,6 +767,7 @@ Source3001: kernel-local
Source3003: Patchlist.changelog
Source4000: README.rst
+Source4001: rpminspect.yaml
## Patches needed for building this package
@@ -856,6 +856,7 @@ It provides the kernel source files common to all builds.
%if %{with_perf}
%package -n perf
Summary: Performance monitoring for the Linux kernel
+Requires: bzip2
License: GPLv2
%description -n perf
This package contains the perf tool, which enables performance monitoring
@@ -1271,8 +1272,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.12-13670-g5e321ded302d -c
-mv linux-5.12-13670-g5e321ded302d linux-%{KVERREL}
+%setup -q -n kernel-5.13-rc1 -c
+mv linux-5.13-rc1 linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -1762,8 +1763,7 @@ BuildKernel() {
if [ -f arch/%{asmarch}/kernel/module.lds ]; then
cp -a --parents arch/%{asmarch}/kernel/module.lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
fi
- rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
- rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
+ find $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts \( -iname "*.o" -o -iname "*.cmd" \) -exec rm -f {} +
%ifarch ppc64le
cp -a --parents arch/powerpc/lib/crtsavres.[So] $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/
%endif
@@ -1983,9 +1983,6 @@ BuildKernel() {
# prune junk from kernel-devel
find $RPM_BUILD_ROOT/usr/src/kernels -name ".*.cmd" -delete
- # build a BLS config for this kernel
- %{SOURCE53} "$KernelVer" "$RPM_BUILD_ROOT" "%{?variant}"
-
# Red Hat UEFI Secure Boot CA cert, which can be used to authenticate the kernel
mkdir -p $RPM_BUILD_ROOT%{_datadir}/doc/kernel-keys/$KernelVer
%ifarch x86_64 aarch64
@@ -2735,7 +2732,6 @@ fi
/lib/modules/%{KVERREL}%{?3:+%{3}}/build\
/lib/modules/%{KVERREL}%{?3:+%{3}}/source\
/lib/modules/%{KVERREL}%{?3:+%{3}}/updates\
-/lib/modules/%{KVERREL}%{?3:+%{3}}/bls.conf\
/lib/modules/%{KVERREL}%{?3:+%{3}}/weak-updates\
%{_datadir}/doc/kernel-keys/%{KVERREL}%{?3:+%{3}}\
%if %{1}\
@@ -2783,6 +2779,40 @@ fi
#
#
%changelog
+* Mon May 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc1.13]
+- Remove unused boot loader specification files (David Ward)
+
+* Mon May 10 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc1.12]
+- Revert "Merge branch 'fix-tag-check' into 'os-build'" (Justin Forbes)
+- Enable CONFIG_DRM_AMDGPU_USERPTR for everyone (Justin M. Forbes)
+- redhat: add initial rpminspect configuration (Herton R. Krzesinski)
+
+* Sat May 08 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc0.20210507gita48b0872e694.11]
+- fedora: arm updates for 5.13 (Peter Robinson)
+- fedora: Enable WWAN and associated MHI bits (Peter Robinson)
+- Update CONFIG_MODPROBE_PATH to /usr/sbin (Justin Forbes)
+- Fedora set modprobe path (Justin M. Forbes)
+
+* Fri May 07 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc0.20210507gita48b0872e694.10]
+- Keep sctp and l2tp modules in modules-extra (Don Zickus)
+- Fix ppc64le cross build packaging (Don Zickus)
+- Fedora: Make amd_pinctrl module builtin (Hans de Goede)
+
+* Thu May 06 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc0.20210506git8404c9fbc84b.9]
+- Keep CONFIG_KASAN_HW_TAGS off for aarch64 debug configs (Justin M. Forbes)
+- New configs in drivers/bus (Fedora Kernel Team)
+- RHEL: Don't build KVM PR module on ppc64 (David Gibson) [1930649]
+
+* Wed May 05 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc0.20210505gitd665ea6ea86c.8]
+- Flip CONFIG_USB_ROLE_SWITCH from m to y (Justin M. Forbes)
+- Set valid options for CONFIG_FW_LOADER_USER_HELPER (Justin M. Forbes)
+- Clean up CONFIG_FB_MODE_HELPERS (Justin M. Forbes)
+- Turn off CONFIG_VFIO for the s390x zfcpdump kernel (Justin M. Forbes)
+- Delete unused CONFIG_SND_SOC_MAX98390 pending-common (Justin M. Forbes)
+- Update pending-common configs, preparing to set correctly (Justin M. Forbes)
+- Update fedora filters for surface (Justin M. Forbes)
+- Build CONFIG_CRYPTO_ECDSA inline for s390x zfcpdump (Justin M. Forbes)
+
* Tue May 04 2021 Fedora Kernel Team <kernel-team@fedoraproject.org> [5.13.0-0.rc0.20210504git5e321ded302d.7]
- Fix branch creation for releases based on tags (Jeremy Cline)
- Replace "flavour" where "variant" is meant instead (David Ward)