summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2021-03-17 19:24:58 +0100
committerThorsten Leemhuis <fedora@leemhuis.info>2021-03-17 19:24:58 +0100
commit163b62e8bc3e36364e324a9a8caf7f13fc954ff5 (patch)
tree1585e5d54beb404114eab9587302339c79239dc1 /kernel.spec
parent8a108017f0aeb33c42f93ca67c37601522ad81ea (diff)
parentee22e4872dec1ab1f08fabe765e18b945ebcc29e (diff)
downloadkernel-163b62e8bc3e36364e324a9a8caf7f13fc954ff5.tar.gz
kernel-163b62e8bc3e36364e324a9a8caf7f13fc954ff5.tar.xz
kernel-163b62e8bc3e36364e324a9a8caf7f13fc954ff5.zip
Diffstat (limited to 'kernel.spec')
-rwxr-xr-xkernel.spec56
1 files changed, 49 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index 14a6198cf..7a1b11f10 100755
--- a/kernel.spec
+++ b/kernel.spec
@@ -105,18 +105,17 @@ Summary: The Linux kernel
%else
%define primary_target rhel
%endif
+%define fedorabase 5.11.7
-%define rpmversion 5.11.6
+%define rpmversion 5.11.7
%define stableversion 5.11
-
-%define pkgrelease 300
+%define pkgrelease 350
# This is needed to do merge window version magic
%define patchlevel 11
# allow pkg_release to have configurable %%{?dist} tag
%define specrelease 350%{?buildid}%{?dist}
-%define fedorabase 5.11.4
%define pkg_release %{specrelease}
@@ -607,7 +606,7 @@ BuildRequires: asciidoc
# exact git commit you can run
#
# xzcat -qq ${TARBALL} | git get-tar-commit-id
-Source0: linux-5.11.6.tar.xz
+Source0: linux-5.11.7.tar.xz
Source1: Makefile.rhelver
@@ -1257,8 +1256,8 @@ ApplyOptionalPatch()
fi
}
-%setup -q -n kernel-5.11.6 -c
-mv linux-5.11.6 linux-%{KVERREL}
+%setup -q -n kernel-5.11.7 -c
+mv linux-5.11.7 linux-%{KVERREL}
cd linux-%{KVERREL}
# cp -a %{SOURCE1} .
@@ -1595,6 +1594,7 @@ BuildKernel() {
(cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
# dirs for additional modules per module-init-tools, kbuild/modules.txt
mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
+ mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/weak-updates
# CONFIG_KERNEL_HEADER_TEST generates some extra files in the process of
# testing so just delete
find . -name *.h.s -delete
@@ -2475,6 +2475,12 @@ fi\
#
%define kernel_variant_posttrans() \
%{expand:%%posttrans %{?1:%{1}-}core}\
+%if 0%{!?fedora:1}\
+if [ -x %{_sbindir}/weak-modules ]\
+then\
+ %{_sbindir}/weak-modules --add-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
+fi\
+%endif\
/bin/kernel-install add %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
%{nil}
@@ -2504,6 +2510,10 @@ fi}\
%define kernel_variant_preun() \
%{expand:%%preun %{?1:%{1}-}core}\
/bin/kernel-install remove %{KVERREL}%{?1:+%{1}} /lib/modules/%{KVERREL}%{?1:+%{1}}/vmlinuz || exit $?\
+if [ -x %{_sbindir}/weak-modules ]\
+then\
+ %{_sbindir}/weak-modules --remove-kernel %{KVERREL}%{?1:+%{1}} || exit $?\
+fi\
%{nil}
%kernel_variant_preun
@@ -2715,6 +2725,7 @@ fi
/lib/modules/%{KVERREL}%{?3:+%{3}}/source\
/lib/modules/%{KVERREL}%{?3:+%{3}}/updates\
/lib/modules/%{KVERREL}%{?3:+%{3}}/bls.conf\
+/lib/modules/%{KVERREL}%{?3:+%{3}}/weak-updates\
%{_datadir}/doc/kernel-keys/%{KVERREL}%{?3:+%{3}}\
%if %{1}\
/lib/modules/%{KVERREL}%{?3:+%{3}}/vdso\
@@ -2761,6 +2772,37 @@ fi
#
#
%changelog
+* Wed Mar 17 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.7-9]
+- Disable weak-modules again rhbz 1828455 (Justin M. Forbes)
+- More config updates for gcc-plugin turn off (Justin M. Forbes)
+- fedora: the PCH_CAN driver is x86-32 only (Peter Robinson)
+- common: disable legacy CAN device support (Peter Robinson)
+- common: Enable Microchip MCP251x/MCP251xFD CAN controllers (Peter Robinson)
+- common: Bosch MCAN support for Intel Elkhart Lake (Peter Robinson)
+- common: enable CAN_PEAK_PCIEFD PCI-E driver (Peter Robinson)
+- common: disable CAN_PEAK_PCIEC PCAN-ExpressCard (Peter Robinson)
+- common: enable common CAN layer 2 protocols (Peter Robinson)
+- ark: disable CAN_LEDS option (Peter Robinson)
+
+* Thu Mar 11 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.6-8]
+- Forgot to turn this back on when disabling gcc plugins (Justin M. Forbes)
+- Fedora: Turn on SND_SOC_INTEL_SKYLAKE_HDAUDIO_CODEC option (Hans de Goede)
+- common: enable RTC_SYSTOHC to supplement update_persistent_clock64 (Peter Robinson)
+- Disable structleak gcc-plugins until a solution is upstream (Justin M. Forbes)
+- mmc: sdhci-iproc: Add ACPI bindings for the rpi (Jeremy Linton)
+- ACPI: platform: Hide ACPI_PLATFORM_PROFILE option (Maximilian Luz)
+- platform/x86: ideapad-laptop: DYTC Platform profile support (Jiaxun Yang)
+- platform/x86: thinkpad_acpi: Replace ifdef CONFIG_ACPI_PLATFORM_PROFILE with depends on (Hans de Goede)
+- platform/x86: thinkpad_acpi: Add platform profile support (Mark Pearson)
+- platform/x86: thinkpad_acpi: fixed warning and incorporated review comments (Nitin Joshi)
+- platform/x86: thinkpad_acpi: Don't register keyboard_lang unnecessarily (Hans de Goede)
+- platform/x86: thinkpad_acpi: set keyboard language (Nitin Joshi)
+- ACPI: platform-profile: Fix possible deadlock in platform_profile_remove() (Hans de Goede)
+- ACPI: platform-profile: Introduce object pointers to callbacks (Jiaxun Yang)
+- ACPI: platform-profile: Drop const qualifier for cur_profile (Jiaxun Yang)
+- ACPI: platform: Add platform profile support (Mark Pearson)
+- Documentation: Add documentation for new platform_profile sysfs attribute (Mark Pearson)
+
* Tue Mar 09 2021 Justin M. Forbes <jforbes@fedoraproject.org> [5.11.5-7]
- Turn on SND_SOC_INTEL_SOUNDWIRE_SOF_MACH for Fedora again (Justin M. Forbes)