summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJosh Boyer <jwboyer@redhat.com>2013-03-04 16:42:47 -0500
committerJosh Boyer <jwboyer@redhat.com>2013-03-04 16:43:56 -0500
commit68c1caae275588ecb959789e22babd25fce9771b (patch)
tree5c119e4c6918599a9e544b8921d843ba54a7b39a /kernel.spec
parent5341f551988c1684421644c89228133ac95aef25 (diff)
downloadkernel-68c1caae275588ecb959789e22babd25fce9771b.tar.gz
kernel-68c1caae275588ecb959789e22babd25fce9771b.tar.xz
kernel-68c1caae275588ecb959789e22babd25fce9771b.zip
Linux v3.9-rc1
- Add patch from Dirk Brandewie to fix intel pstate divide error (rhbz 916833) - Disable debugging options.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/kernel.spec b/kernel.spec
index fca4780a5..ae9c9dae2 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -93,9 +93,9 @@ Summary: The Linux kernel
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
# The rc snapshot level
-%define rcrev 0
+%define rcrev 1
# The git snapshot level
-%define gitrev 15
+%define gitrev 0
# Set rpm version accordingly
%define rpmversion 3.%{upstream_sublevel}.0
%endif
@@ -157,7 +157,7 @@ Summary: The Linux kernel
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
-%define debugbuildsenabled 0
+%define debugbuildsenabled 1
# Want to build a vanilla kernel build without any non-upstream patches?
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
@@ -170,7 +170,7 @@ Summary: The Linux kernel
%define doc_build_fail true
%endif
-%define rawhide_skip_docs 1
+%define rawhide_skip_docs 0
%if 0%{?rawhide_skip_docs}
%define with_doc 0
%define doc_build_fail true
@@ -708,7 +708,6 @@ Patch21000: arm-export-read_current_timer.patch
Patch21004: arm-tegra-nvec-kconfig.patch
Patch21005: arm-tegra-usb-no-reset-linux33.patch
# https://patchwork.kernel.org/patch/2106061/
-Patch21006: arm-tegra-ahb.patch
# versatile
@@ -736,6 +735,9 @@ Patch21261: 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
#rhbz 914737
Patch21262: x86-mm-Fix-vmalloc_fault-oops-during-lazy-MMU-updates.patch
+#rhbz 916833
+Patch21263: intel-pstate-do-not-load-on-VM-that-do-not-report-max-P-state.patch
+
Patch22000: weird-root-dentry-name-debug.patch
#selinux ptrace child permissions
@@ -1296,7 +1298,6 @@ ApplyPatch vmbugon-warnon.patch
ApplyPatch arm-export-read_current_timer.patch
# ApplyPatch arm-tegra-nvec-kconfig.patch
ApplyPatch arm-tegra-usb-no-reset-linux33.patch
-ApplyPatch arm-tegra-ahb.patch
#
# bugfixes to drivers and filesystems
@@ -1430,6 +1431,9 @@ ApplyPatch 0001-kmsg-Honor-dmesg_restrict-sysctl-on-dev-kmsg.patch
#rhbz 914737
ApplyPatch x86-mm-Fix-vmalloc_fault-oops-during-lazy-MMU-updates.patch
+#rhbz 916833
+ApplyPatch intel-pstate-do-not-load-on-VM-that-do-not-report-max-P-state.patch
+
# END OF PATCH APPLICATIONS
%endif
@@ -2271,6 +2275,11 @@ fi
# ||----w |
# || ||
%changelog
+* Mon Mar 04 2013 Josh Boyer <jwboyer@redhat.com> - 3.9.0-0.rc1.git0.1
+- Linux v3.9-rc1
+- Add patch from Dirk Brandewie to fix intel pstate divide error (rhbz 916833)
+- Disable debugging options.
+
* Mon Mar 4 2013 Peter Robinson <pbrobinson@fedoraproject.org>
- Update vexpress and omap options (fix MMC on qemu, hopefully fix OMAP3)