summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorThorsten Leemhuis <fedora@leemhuis.info>2019-01-18 09:17:45 +0100
committerThorsten Leemhuis <fedora@leemhuis.info>2019-01-18 09:17:45 +0100
commit92c7cbe86f8dc7edaaf10babe73f705823870161 (patch)
tree38892e8ba41a106d2eccca5f4f4eddd65fbe2073 /kernel.spec
parent8e849604f07e891b94a459a92b592970b98203f3 (diff)
parent4e727c9e052db0e6812f06f436ca87507619dd9b (diff)
downloadkernel-92c7cbe86f8dc7edaaf10babe73f705823870161.tar.gz
kernel-92c7cbe86f8dc7edaaf10babe73f705823870161.tar.xz
kernel-92c7cbe86f8dc7edaaf10babe73f705823870161.zip
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec87
1 files changed, 44 insertions, 43 deletions
diff --git a/kernel.spec b/kernel.spec
index e3e5c62f5..0d6e0c2f0 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -44,13 +44,13 @@ Summary: The Linux kernel
# For non-released -rc kernels, this will be appended after the rcX and
# gitX tags, so a 3 here would become part of release "0.rcX.gitX.3"
#
-%global baserelease 350
+%global baserelease 250
%global fedora_build %{baserelease}
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 19
+%define base_sublevel 20
## If this is a released kernel ##
%if 0%{?released_kernel}
@@ -58,7 +58,7 @@ Summary: The Linux kernel
%define stable_rc 0
# Do we have a -stable update to apply?
-%define stable_update 16
+%define stable_update 3
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -75,7 +75,7 @@ Summary: The Linux kernel
# The next upstream release sublevel (base_sublevel+1)
%define upstream_sublevel %(echo $((%{base_sublevel} + 1)))
# The rc snapshot level
-%global rcrev 0
+%global rcrev 7
# The git snapshot level
%define gitrev 0
# Set rpm version accordingly
@@ -133,7 +133,7 @@ Summary: The Linux kernel
%define debugbuildsenabled 1
# Kernel headers are being split out into a separate package
-%if 0%{fedora}
+%if 0%{?fedora}
%define with_headers 0
%define with_cross_headers 0
%endif
@@ -399,7 +399,9 @@ Requires: kernel-modules-uname-r = %{KVERREL}%{?variant}
BuildRequires: kmod, patch, bash, tar, git-core
BuildRequires: bzip2, xz, findutils, gzip, m4, perl-interpreter, perl-Carp, perl-devel, perl-generators, make, diffutils, gawk
BuildRequires: gcc, binutils, redhat-rpm-config, hmaccalc, bison, flex
-BuildRequires: net-tools, hostname, bc, elfutils-devel
+BuildRequires: net-tools, hostname, bc, elfutils-devel, gcc-plugin-devel
+# Used to mangle unversioned shebangs to be Python 3
+BuildRequires: /usr/bin/pathfix.py
%if %{with_sparse}
BuildRequires: sparse
%endif
@@ -475,10 +477,6 @@ Source43: generate_bls_conf.sh
# added for those wanting to do custom rebuilds with altered config opts.
Source1000: kernel-local
-# Sources for kernel-tools
-Source2000: cpupower.service
-Source2001: cpupower.config
-
# Here should be only the patches up to the upstream canonical Linus tree.
# For a stable release kernel
@@ -596,34 +594,36 @@ Patch305: qcom-msm89xx-fixes.patch
# https://patchwork.kernel.org/project/linux-mmc/list/?submitter=71861
Patch306: arm-sdhci-esdhc-imx-fixes.patch
-# https://www.spinics.net/lists/arm-kernel/msg670137.html
-Patch307: arm64-ZynqMP-firmware-clock-drivers-core.patch
+# https://patchwork.kernel.org/patch/10686407/
+Patch331: raspberrypi-Fix-firmware-calls-with-large-buffers.patch
-Patch308: arm64-96boards-Rock960-CE-board-support.patch
-Patch309: arm64-rockchip-add-initial-Rockpro64.patch
-Patch310: arm64-rk3399-add-idle-states.patch
+# Improve raspberry pi camera and analog audio
+Patch332: bcm2836-Improve-VCHIQ-cache-line-size-handling.patch
+Patch333: bcm2835-vc04_services-Improve-driver-load-unload.patch
-Patch311: gpio-pxa-handle-corner-case-of-unprobed-device.patch
+# Initall support for the 3A+
+Patch334: bcm2837-dts-add-Raspberry-Pi-3-A.patch
-Patch330: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
+# Fixes for bcm2835 mmc (sdcard) driver
+Patch335: bcm2835-mmc-Several-fixes-for-bcm2835-driver.patch
-# https://patchwork.kernel.org/patch/10686407/
-Patch332: raspberrypi-Fix-firmware-calls-with-large-buffers.patch
+# https://patchwork.kernel.org/patch/10741809/
+Patch336: bcm2835-mmc-sdhci-iproc-handle-mmc_of_parse-errors-during-probe.patch
-# From 4.20, fix eth link/act lights on 3B+
-Patch334: bcm2837-fix-eth-leds.patch
+# https://www.spinics.net/lists/arm-kernel/msg699583.html
+Patch337: ARM-dts-bcm283x-Several-DTS-improvements.patch
-# https://patchwork.kernel.org/patch/10741809/
-Patch335: bcm2835-mmc-sdhci-iproc-handle-mmc_of_parse-errors-during-probe.patch
+Patch339: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
# Patches enabling device specific brcm firmware nvram
# https://www.spinics.net/lists/linux-wireless/msg178827.html
Patch340: brcmfmac-Remove-firmware-loading-code-duplication.patch
+Patch341: brcmfmac-Call-brcmf_dmi_probe-before-brcmf_of_probe.patch
+
# Fix for AllWinner A64 Timer Errata, still not final
-# https://patchwork.kernel.org/patch/10392891/
-Patch350: arm64-arch_timer-Workaround-for-Allwinner-A64-timer-instability.patch
-Patch351: arm64-dts-allwinner-a64-Enable-A64-timer-workaround.patch
+# https://www.spinics.net/lists/arm-kernel/msg699622.html
+Patch350: Allwinner-A64-timer-workaround.patch
# 400 - IBM (ppc/s390x) patches
@@ -635,29 +635,17 @@ Patch501: Fix-for-module-sig-verification.patch
# rhbz 1431375
Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
-# Ena fixes from 4.20
-Patch503: ena-fixes.patch
-
-# rhbz 1526312, patch is in 4.20, can be dropped on rebase
-Patch507: 0001-HID-i2c-hid-override-HID-descriptors-for-certain-dev.patch
-
-# Patches from 4.20 fixing black screen on CHT devices with i915.fastboot=1
-Patch508: cherrytrail-pwm-lpss-fixes.patch
-
# rhbz 1526312 (accelerometer part of the bug), patches pending upstream
-Patch510: iio-accel-kxcjk1013-Add-more-hardware-ids.patch
+Patch504: iio-accel-kxcjk1013-Add-more-hardware-ids.patch
# rhbz 1645070 patch queued upstream for merging into 4.21
-Patch516: asus-fx503-keyb.patch
-
-# rhbz 1661961 patch merged upstream in 4.20
-Patch517: 0001-Bluetooth-btsdio-Do-not-bind-to-non-removable-BCM434.patch
+Patch505: asus-fx503-keyb.patch
# CVE-2019-3701 rhbz 1663729 1663730
-Patch518: CVE-2019-3701.patch
+Patch506: CVE-2019-3701.patch
-# CVE-2019-3459 and CVE-2019-3460 rbhz 1663176 1663179 1665925
-Patch519: CVE-2019-3459-and-CVE-2019-3460.patch
+# CVE-2019-3459 and CVE-2019-3460 rhbz 1663176 1663179 1665925
+Patch507: CVE-2019-3459-and-CVE-2019-3460.patch
# END OF PATCH DEFINITIONS
@@ -1207,6 +1195,16 @@ find . \( -name "*.orig" -o -name "*~" \) -delete >/dev/null
# remove unnecessary SCM files
find . -name .gitignore -delete >/dev/null
+# Mangle /usr/bin/python shebangs to /usr/bin/python3
+# Mangle all Python shebangs to be Python 3 explicitly
+# -p preserves timestamps
+# -n prevents creating ~backup files
+# -i specifies the interpreter for the shebang
+pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/
+pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/diffconfig
+pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/bloat-o-meter
+pathfix.py -pni "%{__python3} %{py3_shbang_opts}" scripts/show_delta
+
cd ..
###
@@ -1923,6 +1921,9 @@ fi
#
#
%changelog
+* Thu Jan 17 2019 Justin M. Forbes <jforbes@fedoraproject.org> - 4.20.3-200
+- Linux v4.20.3 rebase
+
* Mon Jan 14 2019 Jeremy Cline <jcline@redhat.com> - 4.19.15-300
- Linux v4.19.15
- Fix CVE-2019-3459 and CVE-2019-3460 (rbhz 1663176 1663179 1665925)