summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorJeremy Cline <jcline@redhat.com>2018-10-23 09:55:11 -0400
committerJeremy Cline <jcline@redhat.com>2018-11-14 15:31:38 -0500
commit7452c29bbbbaa49fdd659967520375c2d635c8da (patch)
treea0651f3059123f7559ff44cf72f9ffc9bcb30e82 /kernel.spec
parent96b8cd25d54d57f18ad601037f968e2b91e4b015 (diff)
downloadkernel-7452c29bbbbaa49fdd659967520375c2d635c8da.tar.gz
kernel-7452c29bbbbaa49fdd659967520375c2d635c8da.tar.xz
kernel-7452c29bbbbaa49fdd659967520375c2d635c8da.zip
Linux v4.19.2
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec49
1 files changed, 25 insertions, 24 deletions
diff --git a/kernel.spec b/kernel.spec
index 85920565a..96d069cec 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -48,13 +48,13 @@ Summary: The Linux kernel
# base_sublevel is the kernel version we're starting with and patching
# on top of -- for example, 3.1-rc7-git1 starts with a 3.0 base,
# which yields a base_sublevel of 0.
-%define base_sublevel 18
+%define base_sublevel 19
## If this is a released kernel ##
%if 0%{?released_kernel}
# Do we have a -stable update to apply?
-%define stable_update 18
+%define stable_update 2
# Set rpm version accordingly
%if 0%{?stable_update}
%define stablerev %{stable_update}
@@ -127,8 +127,10 @@ Summary: The Linux kernel
%define debugbuildsenabled 1
# Kernel headers are being split out into a separate package
+%if 0%{fedora}
%define with_headers 0
%define with_cross_headers 0
+%endif
%if %{with_verbose}
%define make_opts V=1
@@ -451,8 +453,6 @@ Source24: kernel-armv7hl-lpae.config
Source25: kernel-armv7hl-lpae-debug.config
Source26: kernel-i686.config
Source27: kernel-i686-debug.config
-Source28: kernel-i686-PAE.config
-Source29: kernel-i686-PAEdebug.config
Source30: kernel-ppc64.config
Source31: kernel-ppc64-debug.config
Source32: kernel-ppc64le.config
@@ -534,7 +534,7 @@ Patch117: lis3-improve-handling-of-null-rate.patch
Patch118: scsi-sd_revalidate_disk-prevent-NULL-ptr-deref.patch
-Patch119: criu-no-expert.patch
+Patch119: namespaces-no-expert.patch
Patch120: ath9k-rx-dma-stop-check.patch
@@ -569,7 +569,6 @@ Patch210: disable-i8042-check-on-apple-mac.patch
Patch211: drm-i915-hush-check-crtc-state.patch
Patch212: efi-secureboot.patch
-Patch213: lockdown-fix-coordination-of-kernel-module-signature-verification.patch
# 300 - ARM patches
Patch300: arm64-Add-option-of-13-for-FORCE_MAX_ZONEORDER.patch
@@ -590,17 +589,21 @@ Patch305: qcom-msm89xx-fixes.patch
# https://patchwork.kernel.org/project/linux-mmc/list/?submitter=71861
Patch306: arm-sdhci-esdhc-imx-fixes.patch
-# https://patchwork.kernel.org/patch/10539291/
-Patch308: mmc-sunxi-allow-3.3V-DDR-when-DDR-is-available.patch
-# https://patchwork.kernel.org/patch/10540521/
-Patch309: mmc-sunxi-remove-output-of-virtual-base-address.patch
-
# https://www.spinics.net/lists/arm-kernel/msg670137.html
-Patch311: arm64-ZynqMP-firmware-clock-drivers-core.patch
+Patch307: arm64-ZynqMP-firmware-clock-drivers-core.patch
+
+Patch308: arm64-96boards-Rock960-CE-board-support.patch
+Patch309: arm64-rockchip-add-initial-Rockpro64.patch
+
+Patch310: gpio-pxa-handle-corner-case-of-unprobed-device.patch
-# Enabling Patches for the RPi3+
-Patch330: bcm2837-enable-pmu.patch
+Patch330: bcm2835-cpufreq-add-CPU-frequency-control-driver.patch
+Patch331: bcm283x-drm-vc4-set-is_yuv-to-false-when-num_planes-1.patch
+
+# Patches enabling device specific brcm firmware nvram
+# https://www.spinics.net/lists/linux-wireless/msg178827.html
+Patch340: brcmfmac-Remove-firmware-loading-code-duplication.patch
# Fix for AllWinner A64 Timer Errata, still not final
# https://patchwork.kernel.org/patch/10392891/
@@ -617,16 +620,9 @@ Patch501: Fix-for-module-sig-verification.patch
# rhbz 1431375
Patch502: input-rmi4-remove-the-need-for-artifical-IRQ.patch
-# rhbz 1572944
-Patch506: 0001-random-add-a-config-option-to-trust-the-CPU-s-hwrng.patch
-Patch507: 0001-random-make-CPU-trust-a-boot-parameter.patch
-
-# rhbz 1249364, patch accepted upstream and CCed for stable
-Patch508: ALSA-hda-Add-mic-quirk-for-the-Lenovo-G50-30-17aa-39.patch
-
# Fix known regression
-Patch509: CI-1-6-drm-i915-dp-Fix-link-retraining-comment-in-intel_dp_long_pulse.patch
-Patch510: CI-2-6-drm-i915-dp-Restrict-link-retrain-workaround-to-external-monitors.patch
+Patch504: CI-1-6-drm-i915-dp-Fix-link-retraining-comment-in-intel_dp_long_pulse.patch
+Patch505: CI-2-6-drm-i915-dp-Restrict-link-retrain-workaround-to-external-monitors.patch
# END OF PATCH DEFINITIONS
@@ -1222,7 +1218,9 @@ BuildKernel() {
%endif
# make sure EXTRAVERSION says what we want it to say
- perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -%{release}.%{_target_cpu}${Flav}/" Makefile
+ # Trim the release if this is a CI build, since KERNELVERSION is limited to 64 characters
+ ShortRel=$(python3 -c "import re; print(re.sub(r'\.pr\.[0-9A-Fa-f]{32}', '', '%{release}'))")
+ perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -${ShortRel}.%{_target_cpu}${Flav}/" Makefile
# if pre-rc1 devel kernel, must fix up PATCHLEVEL for our versioning scheme
%if !0%{?rcrev}
@@ -1877,6 +1875,9 @@ fi
#
#
%changelog
+* Wed Nov 14 2018 Jeremy Cline <jcline@redhat.com> - 4.19.2-200
+- Linux v4.19.2
+
* Mon Nov 12 2018 Laura Abbott <labbott@redhat.com> - 4.18.18-200
- Linux v4.18.18