summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorDennis Gilmore <dennis@ausil.us>2012-04-12 10:47:31 -0500
committerDennis Gilmore <dennis@ausil.us>2012-04-12 10:47:31 -0500
commite6eb2f8053824583fdfc268f241f6f26822df913 (patch)
treea9dce10f8a22e70e298545f72869542631d3601c /kernel.spec
parent892e3f4cc024fe8048793199a723d78f81e5a1b2 (diff)
downloadkernel-e6eb2f8053824583fdfc268f241f6f26822df913.tar.gz
kernel-e6eb2f8053824583fdfc268f241f6f26822df913.tar.xz
kernel-e6eb2f8053824583fdfc268f241f6f26822df913.zip
LLSYMS_EXTRA_PASS=1 is only able to be set via environment variables
pass it in on the make line for arm only
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec8
1 files changed, 8 insertions, 0 deletions
diff --git a/kernel.spec b/kernel.spec
index b9579cef9..282938413 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -1596,7 +1596,12 @@ BuildKernel() {
echo USING ARCH=$Arch
make -s ARCH=$Arch oldnoconfig >/dev/null
+%ifarch %{arm}
+ # http://lists.infradead.org/pipermail/linux-arm-kernel/2012-March/091404.html
+ make -s ARCH=$Arch V=1 %{?_smp_mflags} $MakeTarget %{?sparse_mflags} KALLSYMS_EXTRA_PASS=1
+%else
make -s ARCH=$Arch V=1 %{?_smp_mflags} $MakeTarget %{?sparse_mflags}
+%endif
make -s ARCH=$Arch V=1 %{?_smp_mflags} modules %{?sparse_mflags} || exit 1
# Start installing the results
@@ -2307,6 +2312,9 @@ fi
# ||----w |
# || ||
%changelog
+* Thu Apr 12 2012 Dennis Gilmore <dennis@ausil.us>
+- KALLSYMS_EXTRA_PASS=1 has to be passed in on the command line so do so only for arm
+
* Wed Apr 11 2012 Peter Robinson <pbrobinson@fedoraproject.org>
- update ARM configs, rename arm-omap