summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorLaura Abbott <labbott@redhat.com>2019-10-23 15:43:13 -0400
committerLaura Abbott <labbott@redhat.com>2019-10-29 15:28:51 -0400
commitc0312b2e60495b2f82b1748d13f9eb20712a746e (patch)
tree86f98b8977787958a0ae595f9a65497666200d0c /kernel.spec
parentd9864a2973d5262d756db797cb344b65e2d1e801 (diff)
downloadkernel-c0312b2e60495b2f82b1748d13f9eb20712a746e.tar.gz
kernel-c0312b2e60495b2f82b1748d13f9eb20712a746e.tar.xz
kernel-c0312b2e60495b2f82b1748d13f9eb20712a746e.zip
Make turning off configchecks an official ---with option
Fedora does some validation on config options to catch errors. There may be cases when we want to turn off that checking because it doesn't actually matter. Make this a full --with option to make it easier to turn off.
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec20
1 files changed, 11 insertions, 9 deletions
diff --git a/kernel.spec b/kernel.spec
index 8f663d24e..e9968230c 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -149,6 +149,11 @@ Summary: The Linux kernel
# verbose build, i.e. no silent rules and V=1
%define with_verbose %{?_with_verbose: 1} %{?!_with_verbose: 0}
+#
+# check for mismatched config options
+%define with_configchecks %{?_without_configchecks: 0} %{?!_without_configchecks: 1}
+
+#
# gcov support
%define with_gcov %{?_with_gcov: 1} %{?!_with_gcov: 0}
@@ -400,11 +405,7 @@ Summary: The Linux kernel
# Should make listnewconfig fail if there's config options
# printed out?
%if %{nopatches}
-%define listnewconfig_fail 0
-%define configmismatch_fail 0
-%else
-%define listnewconfig_fail 1
-%define configmismatch_fail 1
+%define with_configchecks 0
%endif
# To temporarily exclude an architecture from being built, add it to
@@ -1261,11 +1262,12 @@ done
cp %{SOURCE42} .
OPTS=""
-%if %{listnewconfig_fail}
- OPTS="$OPTS -n"
+%if %{with_configchecks}
+%if 0%{?fedora}
+ OPTS="$OPTS -n -c"
+%else
+ OPTS="$OPTS -w -n -c"
%endif
-%if %{configmismatch_fail}
- OPTS="$OPTS -c"
%endif
./process_configs.sh $OPTS kernel %{rpmversion}