summaryrefslogtreecommitdiffstats
path: root/kernel.spec
diff options
context:
space:
mode:
authorLaura Abbott <labbott@redhat.com>2019-10-31 15:58:53 -0400
committerLaura Abbott <labbott@redhat.com>2019-11-01 16:18:24 -0400
commit581ddc4ac3a77ef124f57b8097b6a885406dcbee (patch)
tree148891a498772b9a4c810d3f317b3a647b1b005f /kernel.spec
parent04b7b3c59b477e5a7e2779a04ab5a3496fd124dc (diff)
downloadkernel-581ddc4ac3a77ef124f57b8097b6a885406dcbee.tar.gz
kernel-581ddc4ac3a77ef124f57b8097b6a885406dcbee.tar.xz
kernel-581ddc4ac3a77ef124f57b8097b6a885406dcbee.zip
Whitespace and other minor cleanups
Diffstat (limited to 'kernel.spec')
-rw-r--r--kernel.spec12
1 files changed, 5 insertions, 7 deletions
diff --git a/kernel.spec b/kernel.spec
index cea540866..bba1de394 100644
--- a/kernel.spec
+++ b/kernel.spec
@@ -184,7 +184,6 @@ Summary: The Linux kernel
# Want to build a vanilla kernel build without any non-upstream patches?
%define with_vanilla %{?_with_vanilla: 1} %{?!_with_vanilla: 0}
-
# Set debugbuildsenabled to 1 for production (build separate debug kernels)
# and 0 for rawhide (all kernels are debug kernels).
# See also 'make debug' and 'make release'.
@@ -329,6 +328,7 @@ Summary: The Linux kernel
%define use_vdso 1
%endif
+
%ifnarch noarch
%define with_kernel_abi_whitelists 0
%endif
@@ -479,7 +479,6 @@ Summary: The Linux kernel
%define _use_vdso 0
%endif
-
#
# Packages that need to be installed before the kernel is, because the %%post
# scripts use them.
@@ -752,6 +751,7 @@ AutoReq: no\
AutoProv: yes\
%{nil}
+
%package doc
Summary: Various documentation bits found in the kernel source
Group: Documentation
@@ -763,6 +763,7 @@ device drivers shipped with it are documented in these files.
You'll want to install this package if you need a reference to the
options that can be passed to Linux kernel modules at load time.
+
%package headers
Summary: Header files for the Linux kernel for use by glibc
Obsoletes: glibc-kernheaders < 3.0-46
@@ -838,7 +839,6 @@ The kabidw-base package contains data describing the current ABI of the Red Hat
Enterprise Linux kernel, suitable for the kabi-dw tool.
%endif
-
#
# This macro creates a kernel-<subpackage>-debuginfo package.
# %%kernel_debuginfo_package <subpackage>
@@ -1314,7 +1314,7 @@ OPTS=""
%endif
cd ..
-# End of Configs stuff
+# # End of Configs stuff
# get rid of unwanted files resulting from patch fuzz
find . \( -name "*.orig" -o -name "*~" \) -delete >/dev/null
@@ -1457,7 +1457,6 @@ BuildKernel() {
cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/lib/modules/$KernelVer/zImage.stub-$KernelVer || :
fi
-
%if %{signkernel}
if [ "$KernelImage" = vmlinux ]; then
# We can't strip and sign $KernelImage in place, because
@@ -1515,7 +1514,6 @@ BuildKernel() {
sha512hmac $RPM_BUILD_ROOT/%{image_install_path}/$InstallName-$KernelVer | sed -e "s,$RPM_BUILD_ROOT,," > $RPM_BUILD_ROOT/%{image_install_path}/.vmlinuz-$KernelVer.hmac;
cp $RPM_BUILD_ROOT/%{image_install_path}/.vmlinuz-$KernelVer.hmac $RPM_BUILD_ROOT/lib/modules/$KernelVer/.vmlinuz.hmac
-
if [ $DoModules -eq 1 ]; then
# Override $(mod-fw) because we don't want it to install any firmware
# we'll get it from the linux-firmware package and we don't want conflicts
@@ -1539,6 +1537,7 @@ BuildKernel() {
$RPM_BUILD_ROOT/etc/ld.so.conf.d/kernel-$KernelVer.conf
echo /etc/ld.so.conf.d/kernel-$KernelVer.conf >> ../kernel${Flavour:+-${Flavour}}-ldsoconf.list
fi
+
rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/vdso/.build-id
fi
@@ -2184,7 +2183,6 @@ fi\
/sbin/depmod -a %{KVERREL}%{?1:+%{1}}\
%{nil}
-
#
# This macro defines a %%post script for a kernel*-modules package.
# It also defines a %%postun script that does the same thing.