summaryrefslogtreecommitdiffstats
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..509f2fb
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,11 @@
+set(anchorman_SRCS
+ anchorman.c
+)
+
+include_directories(${GSTREAMER_INCLUDE_DIRS} ${GUDEV_INCLUDE_DIRS})
+
+add_executable(anchorman ${anchorman_SRCS})
+
+target_link_libraries(anchorman ${GSTREAMER_LIBRARIES} ${GUDEV_LIBRARIES})
+
+install(TARGETS anchorman DESTINATION bin)