summaryrefslogtreecommitdiffstats
path: root/doc/Makefile.am
diff options
context:
space:
mode:
authorfche <fche>2008-02-27 23:11:19 +0000
committerfche <fche>2008-02-27 23:11:19 +0000
commita20617af34e3dbeba682cfa6bf6366f3fc0f8e14 (patch)
treecd840323c6adb32af3f5fa8136a396a3a4f8562b /doc/Makefile.am
parent9a5de18784b77de82e5121861fac892c2d4d2630 (diff)
downloadsystemtap-steved-a20617af34e3dbeba682cfa6bf6366f3fc0f8e14.tar.gz
systemtap-steved-a20617af34e3dbeba682cfa6bf6366f3fc0f8e14.tar.xz
systemtap-steved-a20617af34e3dbeba682cfa6bf6366f3fc0f8e14.zip
PR5697: include tutorial & language reference guide
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 00000000..bf80fbd3
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,28 @@
+# Makefile.am --- automake input file for systemtap docs
+## process this file with automake to produce Makefile.in
+
+if BUILD_DOCS
+all-local: tutorial.pdf langref.pdf
+
+clean-local:
+ rm -f *.pdf *.out *.log *.aux *.toc *.lot *.idx *.glo
+endif
+
+SUFFIXES = ps pdf dvi ps tex
+
+.ps.pdf:
+ ps2pdf -r600 $<
+
+.dvi.ps:
+ dvips -t letter -o $@ $<
+
+.tex.dvi:
+ pwd=`pwd`; cd $(srcdir); \
+ latex -output-directory=$$pwd $<; \
+ touch $*.glo \
+ makeindex $*.glo -s nomencl.ist -o $*.gls \
+ latex -output-directory=$$pwd $<; \
+ latex -output-directory=$$pwd $<; \
+ latex -output-directory=$$pwd $<
+
+EXTRA_DIST = tutorial.tex langref.tex tutorial