summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMark Wielaard <mjw@redhat.com>2009-01-23 15:03:58 +0100
committerMark Wielaard <mjw@redhat.com>2009-01-23 15:03:58 +0100
commit93f864575a8c8123ee8d54cab5e4ea51988e75e7 (patch)
tree73721a87e0ea1158dcb159362dd0af4038d79cf7 /configure.ac
parentf120873cb40cfc16cc94f06fd722abc927b96227 (diff)
downloadsystemtap-steved-93f864575a8c8123ee8d54cab5e4ea51988e75e7.tar.gz
systemtap-steved-93f864575a8c8123ee8d54cab5e4ea51988e75e7.tar.xz
systemtap-steved-93f864575a8c8123ee8d54cab5e4ea51988e75e7.zip
Use install-pkgincludeHEADERS for elfutils configure build step.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 3e0efc95..862a1566 100644
--- a/configure.ac
+++ b/configure.ac
@@ -312,11 +312,11 @@ if test $build_elfutils = yes; then
--prefix="$prefix" \
CFLAGS="${CFLAGS/-Wall/}" \
LDFLAGS="$LDFLAGS $elfutils_rpath" &&
- make -k install-data # so that elfutils/version.h - if any - may be found.
- # Note, we need -k because parts (like to po files) might fail,
- # since those fo to $prefix to which we might not be able to write.
- # We are only really interested in the include-elfutils files anyway here.
+ make install-pkgincludeHEADERS
+ # so that elfutils/version.h - if any - may be found.
+ # Don't use install-data because that will fail (installing in $prefix).
)
+ if test $? != 0; then exit; fi
save_CPPFLAGS=${CPPFLAGS}
CPPFLAGS="${CPPFLAGS} -Iinclude-elfutils" # in case bundled elfutils
AC_CHECK_HEADERS([elfutils/version.h])