summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFrank Ch. Eigler <fche@elastic.org>2009-09-08 21:00:24 -0400
committerFrank Ch. Eigler <fche@elastic.org>2009-09-08 21:00:24 -0400
commite13354499dbd1f854040bc120bdfd1d0fc9ff6b3 (patch)
tree50e5431ae494f5fd71f1e2eff702bf3ac1ef265a /Makefile.am
parent89ba308506249736c6d0c8490d3c897af4e42df8 (diff)
downloadsystemtap-steved-e13354499dbd1f854040bc120bdfd1d0fc9ff6b3.tar.gz
systemtap-steved-e13354499dbd1f854040bc120bdfd1d0fc9ff6b3.tar.xz
systemtap-steved-e13354499dbd1f854040bc120bdfd1d0fc9ff6b3.zip
PR10617: make "make uninstall" work
* Makefile.am (uninstall-local): Don't rm libexecdir but remove doc/exmaples. * Makefile.in: Regenerated.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index c2234d1c..d3edb376 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -270,7 +270,6 @@ distclean-local:
uninstall-local:
rm -rf $(DESTDIR)$(pkgdatadir)
- rm -rf $(DESTDIR)$(libexecdir)/$(PACKAGE)
rm -rf $(DESTDIR)$(libdir)/$(PACKAGE)
-rm -rf $(DESTDIR)$(localstatedir)/cache/$(PACKAGE)
@list='$(EXAMPLE_SRC)'; for f in $$list; do p=`basename $$f`; \
@@ -286,7 +285,7 @@ uninstall-local:
rm -f "$(SAMPLE_INSTALL_DIR)/$$p"; \
done
rm -rf $(DESTDIR)$(sysconfdir)/systemtap
-# XXX: leaves behind man pages
+ rm -rf $(DESTDIR)$(docdir)/examples
SUBDIRS = doc grapher
DIST_SUBDIRS = testsuite $(SUBDIRS)