summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMark Wielaard <mwielaard@redhat.com>2008-08-11 12:11:26 +0200
committerMark Wielaard <mwielaard@redhat.com>2008-08-11 12:11:26 +0200
commit5b8561dccfd6d79184c044cec6bd7d01ef415acc (patch)
tree4b2e03c1ba42cabd188fbb81f2b9d8dc33c08df6 /Makefile.am
parent59ec94081d98239429a440c51744cd90db1d60d7 (diff)
downloadsystemtap-steved-5b8561dccfd6d79184c044cec6bd7d01ef415acc.tar.gz
systemtap-steved-5b8561dccfd6d79184c044cec6bd7d01ef415acc.tar.xz
systemtap-steved-5b8561dccfd6d79184c044cec6bd7d01ef415acc.zip
Use INSTALL_PROGRAM, not INSTALL_DATA for executable .stp scripts.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a601b5fd..e6a5654c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -188,7 +188,10 @@ install-data-local:
| while read f; do $(INSTALL_DATA) -D $$f $(DESTDIR)$(pkgdatadir)/tapset/$$f; done)
(cd $(srcdir)/testsuite/systemtap.examples; find . -type f -print \
| egrep -v 'check.exp|ChangeLog|examples-index-gen.pl' \
- | while read f; do $(INSTALL_DATA) -D $$f $(DESTDIR)$(docdir)/examples/$$f; done)
+ | while read f; do if test -x $$f; then \
+ i_cmd="$(INSTALL_PROGRAM)"; else \
+ i_cmd="$(INSTALL_DATA)"; fi; \
+ $$i_cmd -D $$f $(DESTDIR)$(docdir)/examples/$$f; done)
TEST_COV_DIR = coverage