summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorhunt <hunt>2005-07-27 05:48:11 +0000
committerhunt <hunt>2005-07-27 05:48:11 +0000
commit2dc408207dad62b5c4fa35c187b9c5c4805b9248 (patch)
tree2705285c7600f75f2c04f316cd2aba16702d7a60 /Makefile.am
parent895a9c5c1976404ed6861c7b2dfd1dd150eab561 (diff)
downloadsystemtap-steved-2dc408207dad62b5c4fa35c187b9c5c4805b9248.tar.gz
systemtap-steved-2dc408207dad62b5c4fa35c187b9c5c4805b9248.tar.xz
systemtap-steved-2dc408207dad62b5c4fa35c187b9c5c4805b9248.zip
2005-07-26 Martin Hunt <hunt@redhat.com>
* Makefile.am (stpd_LDFLAGS): Set rpath correclty because otherwise automake doesn't seem to get it right when binaries are in libexec subdirs. (AM_CPPFLAGS): revert. * systemtap.spec.in (LDFLAGS): Set libexecdir here instead.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index de152e92..210424e7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,11 +1,9 @@
# Makefile.am --- automake input file for systemtap
## process this file with automake to produce Makefile.in
-libexecdir = @libexecdir@/@PACKAGE@
-
AM_MAKEFLAGS = 'CXXFLAGS=$(CXXFLAGS)' 'LDFLAGS=$(LDFLAGS)'
-AM_CPPFLAGS = -DPKGLIBDIR='"${libexecdir}"' \
+AM_CPPFLAGS = -DPKGLIBDIR='"${libexecdir}/${PACKAGE}"' \
-DPKGDATADIR='"${datadir}/${PACKAGE}"'
bin_PROGRAMS = stap
@@ -16,7 +14,8 @@ stap_SOURCES = main.cxx \
libexec_PROGRAMS = stpd
stpd_SOURCES = runtime/stpd/stpd.c runtime/stpd/librelay.c
stpd_LDADD = -lpthread
-
+# automake doesn't get rpath right unless we do this
+stpd_LDFLAGS = -Wl,-rpath '$(libdir)/systemtap'
AM_CXXFLAGS = -Wall
# Get extra libs as needed