summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDave Brolley <brolley@redhat.com>2009-01-09 15:19:39 -0500
committerDave Brolley <brolley@redhat.com>2009-01-09 15:19:39 -0500
commit90341d42c4a077c15236e233951472eeeac455f1 (patch)
treeff38a1490bffeb49e9be70e06dd24f6fabde41b0 /Makefile.am
parent64aa100f39dca60999028f83feb31983728ea4d4 (diff)
parentaa5951be9f4f12139cdcec4a501754a62b88c28b (diff)
downloadsystemtap-steved-90341d42c4a077c15236e233951472eeeac455f1.tar.gz
systemtap-steved-90341d42c4a077c15236e233951472eeeac455f1.tar.xz
systemtap-steved-90341d42c4a077c15236e233951472eeeac455f1.zip
Merge branch 'master' of git://sources.redhat.com/git/systemtap
Conflicts: ChangeLog Makefile.am Makefile.in testsuite/ChangeLog
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 15 insertions, 5 deletions
diff --git a/Makefile.am b/Makefile.am
index 76968a49..38a2edaf 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -10,12 +10,18 @@ AM_CPPFLAGS = -DBINDIR='"$(bindir)"' -DPKGDATADIR='"${pkgdatadir}"' -DPKGLIBDIR=
AM_CFLAGS = -D_GNU_SOURCE -fexceptions -Wall -Werror -Wunused -Wformat=2 -W
AM_CXXFLAGS = -Wall -Werror
-man_MANS = stap.1 stapprobes.5 stapfuncs.5 stapvars.5 stapex.5 staprun.8 stap-server.8 man/stapprobes.iosched.5 man/stapprobes.netdev.5 man/stapprobes.nfs.5 man/stapprobes.nfsd.5 man/stapprobes.pagefault.5 man/stapprobes.process.5 man/stapprobes.rpc.5 man/stapprobes.scsi.5 man/stapprobes.signal.5 man/stapprobes.socket.5 man/stapprobes.tcp.5 man/stapprobes.udp.5
+man_MANS = stap.1 stapprobes.5 stapfuncs.5 stapvars.5 stapex.5 staprun.8 man/stapprobes.iosched.5 man/stapprobes.netdev.5 man/stapprobes.nfs.5 man/stapprobes.nfsd.5 man/stapprobes.pagefault.5 man/stapprobes.process.5 man/stapprobes.rpc.5 man/stapprobes.scsi.5 man/stapprobes.signal.5 man/stapprobes.socket.5 man/stapprobes.tcp.5 man/stapprobes.udp.5
# see also configure.ac
-bin_PROGRAMS = stap staprun stap-client-connect stap-server-connect
-bin_SCRIPTS = stap-client stap-serverd stap-server stap-find-servers stap-start-server stap-find-or-start-server stap-stop-server \
- stap-gen-server-cert stap-add-server-cert stap-report
+bin_PROGRAMS = stap staprun
+bin_SCRIPTS = stap-report
+if BUILD_SERVER
+man_MANS += stap-server.8
+bin_PROGRAMS += stap-client-connect stap-server-connect
+bin_SCRIPTS += stap-client stap-serverd stap-server stap-find-servers \
+ stap-start-server stap-find-or-start-server stap-stop-server \
+ stap-gen-server-cert stap-add-server-cert
+endif
stap_SOURCES = main.cxx \
parse.cxx staptree.cxx elaborate.cxx translate.cxx \
tapsets.cxx buildrun.cxx loc2c.c hash.cxx mdfour.c \
@@ -69,9 +75,11 @@ stap_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
staprun_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
stapio_CPPFLAGS = $(AM_CPPFLAGS)
stapio_LDFLAGS = $(AM_LDFLAGS) @PIELDFLAGS@
+
+if BUILD_SERVER
stap_client_connect_LDFLAGS = $(AM_LDFLAGS)
stap_server_connect_LDFLAGS = $(AM_LDFLAGS)
-
+endif
PHONIES =
if BUILD_ELFUTILS
@@ -119,6 +127,7 @@ stapio_SOURCES = runtime/staprun/stapio.c \
stapio_CFLAGS = @PROCFLAGS@ $(AM_CFLAGS) -fno-strict-aliasing
stapio_LDADD = @PROCFLAGS@ -lpthread
+if BUILD_SERVER
stap_client_connect_SOURCES = stap-client-connect.c
stap_client_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_client_connect_LDADD = -lssl3
@@ -126,6 +135,7 @@ stap_client_connect_LDADD = -lssl3
stap_server_connect_SOURCES = stap-server-connect.c
stap_server_connect_CFLAGS = -Wall -Werror $(nss_CFLAGS) $(nspr_CFLAGS)
stap_server_connect_LDADD = -lssl3
+endif
install-exec-hook:
if [ `id -u` -eq 0 ]; then chmod 04111 "$(DESTDIR)$(bindir)/staprun"; fi