summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Kölker <jason@koelker.net>2011-09-27 13:03:10 -0500
committerJason Kölker <jason@koelker.net>2011-09-27 13:03:10 -0500
commitd6eae0ebb7378e091ea094e9380a968337e8c32c (patch)
tree302532c34b48d7e9ac7dc75cea09ede32d0b5aaf /setup.py
downloadoslo-d6eae0ebb7378e091ea094e9380a968337e8c32c.tar.gz
oslo-d6eae0ebb7378e091ea094e9380a968337e8c32c.tar.xz
oslo-d6eae0ebb7378e091ea094e9380a968337e8c32c.zip
initial commit
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py32
1 files changed, 32 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..fa3dd3d
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,32 @@
+from setuptools import setup, find_packages
+
+version = '0.1'
+
+setup(name='openstack.commons',
+ version=version,
+ description="Common components for Openstack",
+ long_description="""\
+Common components for Openstack including paster templates.
+""",
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'License :: OSI Approved :: Apache Software License',
+ 'Operating System :: POSIX :: Linux',
+ 'Programming Language :: Python :: 2.6',
+ 'Environment :: No Input/Output (Daemon)',
+ ],
+ keywords='openstack',
+ author='OpenStack',
+ author_email='openstack@lists.launchpad.net',
+ url='http://www.openstack.org/',
+ license='Apache Software License',
+ packages=find_packages(exclude=['ez_setup', 'examples', 'tests']),
+ include_package_data=True,
+ zip_safe=True,
+ install_requires=[
+ # -*- Extra requirements: -*-
+ ],
+ entry_points="""
+ # -*- Entry points: -*-
+ """,
+ )