summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJason Kölker <jason@koelker.net>2011-11-01 13:33:53 -0500
committerJason Kölker <jason@koelker.net>2011-11-01 13:33:53 -0500
commit04661c1344386ed808b43a5992710efab9c79bdb (patch)
tree166a4494875ef0d96d8c4695814e866920ca7542 /setup.py
parent12edc653f55015627b3f51dacf5c15e1d182da34 (diff)
downloadoslo-04661c1344386ed808b43a5992710efab9c79bdb.tar.gz
oslo-04661c1344386ed808b43a5992710efab9c79bdb.tar.xz
oslo-04661c1344386ed808b43a5992710efab9c79bdb.zip
put requires in setup.py so when package gets included as a requirement, the requirements follow along
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 10 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 0d03842..a650ddf 100644
--- a/setup.py
+++ b/setup.py
@@ -24,10 +24,18 @@ Common components for Openstack including paster templates.
include_package_data=True,
zip_safe=True,
install_requires=[
- 'PasteDeploy',
+ 'greenlet>=0.3.1',
+ 'pep8',
+ 'pylint',
'eventlet',
+ 'PasteDeploy',
'routes',
- 'WebOb',
+ 'webob',
+ 'nose',
+ 'nose-exclude',
+ 'mox',
+ 'webtest',
+ 'lxml',
],
entry_points="""
# -*- Entry points: -*-