summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAndrew Laski <andrew.laski@rackspace.com>2012-09-06 21:21:23 -0400
committerAndrew Laski <andrew.laski@rackspace.com>2012-09-07 17:47:24 -0400
commitccc0bfb3e636a96c4b165b7657db9edeaa096af9 (patch)
tree83449e77aee32fe36bf3456459fc6b36f817f0c4 /setup.py
parent37cc45b8fdaa199b248a7ef5f683d514733b8387 (diff)
downloadnova-ccc0bfb3e636a96c4b165b7657db9edeaa096af9.tar.gz
nova-ccc0bfb3e636a96c4b165b7657db9edeaa096af9.tar.xz
nova-ccc0bfb3e636a96c4b165b7657db9edeaa096af9.zip
Set install_requires in setup.py.
Updates setup.py to set install_requires using parse_requirements from openstack-common. This allows DevStack to install nova requirements, as currently they are not handled. Also relaxes the version requirement for lxml to >=2.3,<3. This allows DevStack to install nova requirements without needing to install lxml over the installed python-xml system package, currently 2.3.2. Change-Id: Iccebf9604ba5c6fcacb4c5fa5004f9fcb08944f3
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 85bea96ea..5ae22d6a9 100644
--- a/setup.py
+++ b/setup.py
@@ -23,6 +23,7 @@ import setuptools
from nova.openstack.common import setup as common_setup
from nova import version
+requires = common_setup.parse_requirements()
setuptools.setup(name='nova',
version=version.canonical_version_string(),
@@ -32,6 +33,7 @@ setuptools.setup(name='nova',
url='http://www.openstack.org/',
cmdclass=common_setup.get_cmdclass(),
packages=setuptools.find_packages(exclude=['bin', 'smoketests']),
+ install_requires=requires,
include_package_data=True,
test_suite='nose.collector',
setup_requires=['setuptools_git>=0.4'],