summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2013-04-07 18:24:27 -0400
committerMatthew Sherborne <msherborne@gmail.com>2013-05-07 18:38:53 +1000
commitcbe862603eaa7c08bc926208ba46d5ef927e2658 (patch)
tree3ce89c9b27bee6ae219176cd7c294419110dd77c /setup.py
parentc1857d6f4fa432b1e708270cbd46aa19510902e1 (diff)
downloadnova-cbe862603eaa7c08bc926208ba46d5ef927e2658.tar.gz
nova-cbe862603eaa7c08bc926208ba46d5ef927e2658.tar.xz
nova-cbe862603eaa7c08bc926208ba46d5ef927e2658.zip
Transition from openstack.common.setup to pbr.
Declarative approach to packaging, obviates the need for copying files. Also, removes the need for setup.py to import files from the nova module. ./run_tests.sh now ensure's that nova.egg-info/entry_points.txt is up to date before running tests. Change-Id: I7b7a18e065a62491ade54fbed5d8400db1d4e6c7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py89
1 files changed, 15 insertions, 74 deletions
diff --git a/setup.py b/setup.py
index 403e32c72..59a00909e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,80 +1,21 @@
-# vim: tabstop=4 shiftwidth=4 softtabstop=4
-
-# Copyright 2010 United States Government as represented by the
-# Administrator of the National Aeronautics and Space Administration.
-# All Rights Reserved.
+#!/usr/bin/env python
+# Copyright (c) 2013 Hewlett-Packard Development Company, L.P.
#
-# Licensed under the Apache License, Version 2.0 (the "License"); you may
-# not use this file except in compliance with the License. You may obtain
-# a copy of the License at
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
#
-# http://www.apache.org/licenses/LICENSE-2.0
+# http://www.apache.org/licenses/LICENSE-2.0
#
-# Unless required by applicable law or agreed to in writing, software
-# distributed under the License is distributed on an "AS IS" BASIS, WITHOUT
-# WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the
-# License for the specific language governing permissions and limitations
-# under the License.
-import setuptools
-
-from nova.openstack.common import setup as common_setup
-
-requires = common_setup.parse_requirements()
-depend_links = common_setup.parse_dependency_links()
-project = 'nova'
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or
+# implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+import setuptools
setuptools.setup(
- name=project,
- version=common_setup.get_version(project, '2013.2'),
- description='cloud computing fabric controller',
- author='OpenStack',
- author_email='nova@lists.launchpad.net',
- url='http://www.openstack.org/',
- classifiers=[
- 'Environment :: OpenStack',
- 'Intended Audience :: Information Technology',
- 'Intended Audience :: System Administrators',
- 'License :: OSI Approved :: Apache Software License',
- 'Operating System :: POSIX :: Linux',
- 'Programming Language :: Python',
- 'Programming Language :: Python :: 2',
- 'Programming Language :: Python :: 2.7',
- ],
- cmdclass=common_setup.get_cmdclass(),
- packages=setuptools.find_packages(exclude=['bin', 'smoketests']),
- install_requires=requires,
- dependency_links=depend_links,
- include_package_data=True,
- test_suite='nose.collector',
- setup_requires=['setuptools_git>=0.4'],
- entry_points={
- 'console_scripts': [
- 'nova-all = nova.cmd.all:main',
- 'nova-api = nova.cmd.api:main',
- 'nova-api-ec2 = nova.cmd.api_ec2:main',
- 'nova-api-metadata = nova.cmd.api_metadata:main',
- 'nova-api-os-compute = nova.cmd.api_os_compute:main',
- 'nova-baremetal-deploy-helper'
- ' = nova.cmd.baremetal_deploy_helper:main',
- 'nova-baremetal-manage = nova.cmd.baremetal_manage:main',
- 'nova-rpc-zmq-receiver = nova.cmd.rpc_zmq_receiver:main',
- 'nova-cells = nova.cmd.cells:main',
- 'nova-cert = nova.cmd.cert:main',
- 'nova-clear-rabbit-queues = nova.cmd.clear_rabbit_queues:main',
- 'nova-compute = nova.cmd.compute:main',
- 'nova-conductor = nova.cmd.conductor:main',
- 'nova-console = nova.cmd.console:main',
- 'nova-consoleauth = nova.cmd.consoleauth:main',
- 'nova-dhcpbridge = nova.cmd.dhcpbridge:main',
- 'nova-manage = nova.cmd.manage:main',
- 'nova-network = nova.cmd.network:main',
- 'nova-novncproxy = nova.cmd.novncproxy:main',
- 'nova-objectstore = nova.cmd.objectstore:main',
- 'nova-rootwrap = nova.cmd.rootwrap:main',
- 'nova-scheduler = nova.cmd.scheduler:main',
- 'nova-spicehtml5proxy = nova.cmd.spicehtml5proxy:main',
- 'nova-xvpvncproxy = nova.cmd.xvpvncproxy:main'
- ]
- },
- py_modules=[])
+ setup_requires=['d2to1', 'pbr'],
+ d2to1=True)