summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-08-15 15:02:51 -0400
committerMichael Still <mikal@stillhq.com>2013-04-04 13:14:27 +1100
commit799a925c1f4a388c30a7f0d9e1ffe1b82e8ced9d (patch)
tree596812f9f17ca76741cfec8ca0899a99bd75a7b2 /setup.py
parenta01f907cecc24c18cbe3d32921247125294dd2b9 (diff)
downloadnova-799a925c1f4a388c30a7f0d9e1ffe1b82e8ced9d.tar.gz
nova-799a925c1f4a388c30a7f0d9e1ffe1b82e8ced9d.tar.xz
nova-799a925c1f4a388c30a7f0d9e1ffe1b82e8ced9d.zip
Move console scripts to entrypoints.
As part of the move of plugins to entrypoints, take advantage of the entrypoints based console scripts, which will make our command line scripts available for unittesting. Part of blueprint entrypoints-plugins Co-authored-by: Michael Still <mikal@stillhq.com> Change-Id: I5f17348b7b3cc896c92263dd518abb128757d81f
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py57
1 files changed, 31 insertions, 26 deletions
diff --git a/setup.py b/setup.py
index e4bc7d4a1..403e32c72 100644
--- a/setup.py
+++ b/setup.py
@@ -23,6 +23,7 @@ requires = common_setup.parse_requirements()
depend_links = common_setup.parse_dependency_links()
project = 'nova'
+
setuptools.setup(
name=project,
version=common_setup.get_version(project, '2013.2'),
@@ -47,29 +48,33 @@ setuptools.setup(
include_package_data=True,
test_suite='nose.collector',
setup_requires=['setuptools_git>=0.4'],
- scripts=['bin/nova-all',
- 'bin/nova-api',
- 'bin/nova-api-ec2',
- 'bin/nova-api-metadata',
- 'bin/nova-api-os-compute',
- 'bin/nova-baremetal-deploy-helper',
- 'bin/nova-baremetal-manage',
- 'bin/nova-rpc-zmq-receiver',
- 'bin/nova-cells',
- 'bin/nova-cert',
- 'bin/nova-clear-rabbit-queues',
- 'bin/nova-compute',
- 'bin/nova-conductor',
- 'bin/nova-console',
- 'bin/nova-consoleauth',
- 'bin/nova-dhcpbridge',
- 'bin/nova-manage',
- 'bin/nova-network',
- 'bin/nova-novncproxy',
- 'bin/nova-objectstore',
- 'bin/nova-rootwrap',
- 'bin/nova-scheduler',
- 'bin/nova-spicehtml5proxy',
- 'bin/nova-xvpvncproxy',
- ],
- py_modules=[])
+ entry_points={
+ 'console_scripts': [
+ 'nova-all = nova.cmd.all:main',
+ 'nova-api = nova.cmd.api:main',
+ 'nova-api-ec2 = nova.cmd.api_ec2:main',
+ 'nova-api-metadata = nova.cmd.api_metadata:main',
+ 'nova-api-os-compute = nova.cmd.api_os_compute:main',
+ 'nova-baremetal-deploy-helper'
+ ' = nova.cmd.baremetal_deploy_helper:main',
+ 'nova-baremetal-manage = nova.cmd.baremetal_manage:main',
+ 'nova-rpc-zmq-receiver = nova.cmd.rpc_zmq_receiver:main',
+ 'nova-cells = nova.cmd.cells:main',
+ 'nova-cert = nova.cmd.cert:main',
+ 'nova-clear-rabbit-queues = nova.cmd.clear_rabbit_queues:main',
+ 'nova-compute = nova.cmd.compute:main',
+ 'nova-conductor = nova.cmd.conductor:main',
+ 'nova-console = nova.cmd.console:main',
+ 'nova-consoleauth = nova.cmd.consoleauth:main',
+ 'nova-dhcpbridge = nova.cmd.dhcpbridge:main',
+ 'nova-manage = nova.cmd.manage:main',
+ 'nova-network = nova.cmd.network:main',
+ 'nova-novncproxy = nova.cmd.novncproxy:main',
+ 'nova-objectstore = nova.cmd.objectstore:main',
+ 'nova-rootwrap = nova.cmd.rootwrap:main',
+ 'nova-scheduler = nova.cmd.scheduler:main',
+ 'nova-spicehtml5proxy = nova.cmd.spicehtml5proxy:main',
+ 'nova-xvpvncproxy = nova.cmd.xvpvncproxy:main'
+ ]
+ },
+ py_modules=[])