summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThierry Carrez <thierry@openstack.org>2011-11-21 16:28:02 +0100
committerThierry Carrez <thierry@openstack.org>2011-12-07 15:10:04 +0100
commit3c87de7c12c30d380e12b19dc0473d1e3bcfd233 (patch)
tree7b57ada0d0dc1a0cd512a73fc53fb566040bf95a /setup.py
parent45e31ab90d22cbb84a33c051ee43f273b7a4c38b (diff)
downloadnova-3c87de7c12c30d380e12b19dc0473d1e3bcfd233.tar.gz
nova-3c87de7c12c30d380e12b19dc0473d1e3bcfd233.tar.xz
nova-3c87de7c12c30d380e12b19dc0473d1e3bcfd233.zip
A more secure root-wrapper alternative
Alternative to using a sudoers file to limit which commands can be run as root in Nova. This one makes use of command filters defined in Nova code itself, which can be customized to deeply inspect command arguments before allowing a command to be executed. This change puts the infrastructure in place, together with command filters that replicate the level of filtering provided by a sudoers file (no deep argument inspection yet). An example of an advanced filter (RegExpFilter) is also provided. This new root wrapper is not active by default (root_helper still defaults to "sudo"). Implements blueprint nova-rootwrap. Change-Id: I7ad723b55e9446758876f21b4fbb09374a910425
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 1 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 859c20ebc..f44acfcbf 100644
--- a/setup.py
+++ b/setup.py
@@ -104,6 +104,7 @@ setup(name='nova',
'bin/nova-manage',
'bin/nova-network',
'bin/nova-objectstore',
+ 'bin/nova-rootwrap',
'bin/nova-scheduler',
'bin/nova-spoolsentry',
'bin/stack',