summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-01-04 12:39:28 -0800
committerMonty Taylor <mordred@inaugust.com>2012-01-04 12:41:49 -0800
commit10372e7e9a1f5c04a446c1136b57c2320d2eca58 (patch)
treeda20090915b5063b131367df42386763ec0bdad3 /setup.py
parent4df633d42072906aad3dfcaf60801dcb04d1e540 (diff)
downloadnova-10372e7e9a1f5c04a446c1136b57c2320d2eca58.tar.gz
nova-10372e7e9a1f5c04a446c1136b57c2320d2eca58.tar.xz
nova-10372e7e9a1f5c04a446c1136b57c2320d2eca58.zip
Remove install_requires processing.
Loading install_requires with the contents of pip-requires isn't getting us any real beneift and is causing issues. a) It can conflict with installing nova into an environment where deps have been installed from packages (devstack) b) It breaks the ability to use -e git urls in pip-requires which we want to start using for python-novaclient and python-keystoneclient c) It causes spurious network traffic when we're trying to test things. At the same time, since we are not expecting anyone to install nova from setup.py for production, the normal benefit of the feature is not needed. Change-Id: I402f975c652dc1c2b54b0c362b8abbb6886f8844
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 0 insertions, 8 deletions
diff --git a/setup.py b/setup.py
index 8aa2a6a12..cf6499782 100644
--- a/setup.py
+++ b/setup.py
@@ -72,13 +72,6 @@ def find_data_files(destdir, srcdir):
return package_data
-def load_required_packages():
- with file('tools/pip-requires', 'r') as f:
- return [line.strip() for line in f]
-
-
-required_packages = load_required_packages()
-
setup(name='nova',
version=version.canonical_version_string(),
description='cloud computing fabric controller',
@@ -90,7 +83,6 @@ setup(name='nova',
include_package_data=True,
test_suite='nose.collector',
data_files=find_data_files('share/nova', 'tools'),
- install_requires=required_packages,
scripts=['bin/nova-ajax-console-proxy',
'bin/nova-api',
'bin/nova-api-ec2',