summaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorMonty Taylor <mordred@inaugust.com>2012-02-08 00:16:50 -0800
committerMonty Taylor <mordred@inaugust.com>2012-02-08 19:30:39 -0800
commitb54179438e53e26a45c8cf046bc3714fe027dc22 (patch)
treebb67691c219ae6de8fe67cf0f21c1ffa1754194d /setup.cfg
parent4a4c274c834728a03bce7e5384c562321821eaf8 (diff)
downloadnova-b54179438e53e26a45c8cf046bc3714fe027dc22.tar.gz
nova-b54179438e53e26a45c8cf046bc3714fe027dc22.tar.xz
nova-b54179438e53e26a45c8cf046bc3714fe027dc22.zip
Move translations to babel locations.
If we structure things like this, we can get things actually, you know, installed. Locales ast and oc aren't supported by babel. We'll re-import them from Launchpad once we get babel updated. If you want translations installed, run: python setup.py compile_catalog Before you run either setup.py sdist or setup.py install More work is needed to actually properly use the installed translations, but we're closer. Change-Id: I4a4bedd982c89063aa09688c9cbcf97054bcb34b
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index 18179b152..6588b199f 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -9,18 +9,18 @@ tag_date = 0
tag_svn_revision = 0
[compile_catalog]
-directory = locale
+directory = nova/locale
domain = nova
[update_catalog]
domain = nova
-output_dir = po
-input_file = po/nova.pot
+output_dir = nova/locale
+input_file = nova/locale/nova.pot
[extract_messages]
-keywords = _ gettext ngettext
+keywords = _ gettext ngettext l_ lazy_gettext
mapping_file = babel.cfg
-output_file = po/nova.pot
+output_file = nova/locale/nova.pot
[nosetests]
verbosity=2