summaryrefslogtreecommitdiffstats
path: root/support/export/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'support/export/Makefile.am')
-rw-r--r--support/export/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/support/export/Makefile.am b/support/export/Makefile.am
new file mode 100644
index 0000000..41769fa
--- /dev/null
+++ b/support/export/Makefile.am
@@ -0,0 +1,46 @@
+## Process this file with automake to produce Makefile.in
+
+RPCGEN = $(top_builddir)/tools/rpcgen/rpcgen
+
+GENFILES_CLNT = mount_clnt.c
+GENFILES_XDR = mount_xdr.c
+GENFILES_H = mount.h
+
+GENFILES = $(GENFILES_CLNT) $(GENFILES_SVC) $(GENFILES_XDR) $(GENFILES_H)
+
+EXTRA_DIST = \
+ mount.x \
+ \
+ keys.c
+
+noinst_LIBRARIES = libexport.a
+libexport_a_SOURCES = client.c export.c hostname.c nfsctl.c rmtab.c \
+ xtab.c mount_clnt.c mount_xdr.c
+BUILT_SOURCES = $(GENFILES)
+
+noinst_HEADERS = mount.h
+
+dist-hook:
+ for f in $(GENFILES); do \
+ rm ${distdir}/$$f; \
+ done
+
+$(RPCGEN):
+ make -C $(top_srcdir)/tools/rpcgen all
+
+$(GENFILES_CLNT): %_clnt.c: %.x $(RPCGEN)
+ test -f $@ && rm -rf $@ || true
+ $(RPCGEN) -l -o $@ $<
+
+$(GENFILES_XDR): %_xdr.c: %.x $(RPCGEN)
+ test -f $@ && rm -rf $@ || true
+ $(RPCGEN) -c -o $@ $<
+
+$(GENFILES_H): %.h: %.x $(RPCGEN)
+ test -f $@ && rm -rf $@ || true
+ $(RPCGEN) -h -o $@ $<
+ $(LN_S) ../export/mount.h $(top_builddir)/support/include/mount.h
+
+MAINTAINERCLEANFILES = Makefile.in
+
+CLEANFILES = $(GENFILES) $(top_builddir)/support/include/mount.h