summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2011-07-12 17:21:09 -0400
committerSteve Dickson <steved@redhat.com>2011-07-12 17:21:49 -0400
commitf3d38a7c84f5be084cd45d5d95e2417f1928bd02 (patch)
tree929323308f2dd2f0da14a393aba18432a346bb2a /configure.ac
parent0062bea7159b3c7516d4d361ef1244d727231936 (diff)
downloadnfs-utils-f3d38a7c84f5be084cd45d5d95e2417f1928bd02.tar.gz
nfs-utils-f3d38a7c84f5be084cd45d5d95e2417f1928bd02.tar.xz
nfs-utils-f3d38a7c84f5be084cd45d5d95e2417f1928bd02.zip
Make sure CONFIG_NFSIDMAP is always defined.
CONFIG_NFSIDMAP always need to be define either negatively or positive whether nfsv4 is or is not defined. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index ca12f9e..f8b0796 100644
--- a/configure.ac
+++ b/configure.ac
@@ -249,6 +249,9 @@ AC_CHECK_FUNC([getservbyname], ,
AC_CHECK_LIB([crypt], [crypt], [LIBCRYPT="-lcrypt"])
+dnl enable nfsidmap when its support by libnfsidmap
+AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$enable_nfsidmap" = "yes"])
+
if test "$enable_nfsv4" = yes; then
dnl check for libevent libraries and headers
AC_LIBEVENT
@@ -256,9 +259,6 @@ if test "$enable_nfsv4" = yes; then
dnl check for nfsidmap libraries and headers
AC_LIBNFSIDMAP
- dnl enable nfsidmap when its support by libnfsidmap
- AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$enable_nfsidmap" = "yes"])
-
dnl check for the keyutils libraries and headers
AC_KEYUTILS