summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@flameeyes.eu>2012-05-29 14:15:32 -0400
committerSteve Dickson <steved@redhat.com>2012-05-29 14:44:17 -0400
commitddb095f82becc94c8e3a2429cc755dee5d1808c9 (patch)
tree28d3186a1d733096e71e5a98c542042c465023e6 /configure.ac
parent7e9c0f760397d7e8fa78bdeefffc14eb8269925b (diff)
downloadnfs-utils-ddb095f82becc94c8e3a2429cc755dee5d1808c9.tar.gz
nfs-utils-ddb095f82becc94c8e3a2429cc755dee5d1808c9.tar.xz
nfs-utils-ddb095f82becc94c8e3a2429cc755dee5d1808c9.zip
build: avoid AM_CONDITIONAL in conditional execution.
Automake does not support conditional AM_CONDITIONAL calls; what that means is that you always have to execute AM_CONDITIONAL one way or the other. Both the libsqlite3.m4 file and the nfsdcld conditionals are executed only when NFSv4 is enabled, which breaks building with --disable-nfsv4. Remove the SQLite3 conditional altogether as it's never used, and move the nfsdcld conditional outside of the conditional code. Acked-by: Jeff Layton <jlayton@redhat.com> Signed-off-by: Diego Elio Pettenò <flameeyes@flameeyes.eu> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 9ba53e2..b408f1b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -278,8 +278,6 @@ if test "$enable_nfsv4" = yes; then
fi
fi
- AM_CONDITIONAL(CONFIG_NFSDCLD, [test "$enable_nfsdcld" = "yes" ])
-
dnl librpcsecgss already has a dependency on libgssapi,
dnl but we need to make sure we get the right version
if test "$enable_gss" = yes; then
@@ -293,6 +291,7 @@ if test "$enable_nfsv41" = yes; then
fi
dnl enable nfsidmap when its support by libnfsidmap
+AM_CONDITIONAL(CONFIG_NFSDCLD, [test "$enable_nfsdcld" = "yes" ])
AM_CONDITIONAL(CONFIG_NFSIDMAP, [test "$ac_cv_header_keyutils_h$ac_cv_lib_nfsidmap_nfs4_owner_to_uid" = "yesyes"])