summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChuck Lever <chuck.lever@oracle.com>2011-09-19 14:02:10 -0400
committerSteve Dickson <steved@redhat.com>2011-09-20 07:33:02 -0400
commitcae84d3a8aecbce0d0115382441f18fd62798f9a (patch)
treefaaaca6d4afa1a59953d9f1778f71dab44e10154 /configure.ac
parentd7c64ddf66b04a225fab249af8a8fdd684551c5c (diff)
downloadnfs-utils-cae84d3a8aecbce0d0115382441f18fd62798f9a.tar.gz
nfs-utils-cae84d3a8aecbce0d0115382441f18fd62798f9a.tar.xz
nfs-utils-cae84d3a8aecbce0d0115382441f18fd62798f9a.zip
configure.ac: Fix help string for --with-statedir= option
The help string for --with-statedir attempts to show "/var/lib/nfs" in square brackets, but they don't appear on my system (Fedora 13). Use the AC_HELP_STRING macro to display the help string properly, like all the other "with" and "enable" options specified in our configure.ac. Signed-off-by: Chuck Lever <chuck.lever@oracle.com> Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1a28f8a..3132fe4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -18,7 +18,8 @@ AC_ARG_WITH(release,
RELEASE=1)
AC_SUBST(RELEASE)
AC_ARG_WITH(statedir,
- [ --with-statedir=/foo use state dir /foo [/var/lib/nfs]],
+ [AC_HELP_STRING([--with-statedir=/foo],
+ [use state dir /foo @<:@default=/var/lib/nfs@:>@])],
statedir=$withval,
statedir=/var/lib/nfs)
AC_SUBST(statedir)