summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSteve Dickson <steved@redhat.com>2010-02-17 14:38:19 -0500
committerSteve Dickson <steved@redhat.com>2010-02-17 14:38:19 -0500
commit6d5ac3fa75024be569b458f4d9b6ce05be47f601 (patch)
tree2d22fd92409c20491b7b3d22beddeb8f60fb556f /configure.ac
parent33203b53ac5f43eef995c100299e45bd441c67d8 (diff)
downloadnfs-utils-6d5ac3fa75024be569b458f4d9b6ce05be47f601.tar.gz
nfs-utils-6d5ac3fa75024be569b458f4d9b6ce05be47f601.tar.xz
nfs-utils-6d5ac3fa75024be569b458f4d9b6ce05be47f601.zip
nfsd: Disble NFS 4.1 functionality by default
Due to the fact the current kernel code do not completely conform to the NFS 4.1 RFC, this patch disable the 4.1 support on the server. To control this 41 functionality, the NFS41_SUPPORTED configuration variable now exist that will allow us to re enable the functionality without any code changes. Signed-off-by: Steve Dickson <steved@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1dc4249..f6b1189 100644
--- a/configure.ac
+++ b/configure.ac
@@ -72,6 +72,20 @@ AC_ARG_ENABLE(nfsv4,
AC_SUBST(IDMAPD)
AC_SUBST(enable_nfsv4)
AM_CONDITIONAL(CONFIG_NFSV4, [test "$enable_nfsv4" = "yes"])
+
+AC_ARG_ENABLE(nfsv41,
+ [AC_HELP_STRING([--enable-nfsv41],
+ [enable support for NFSv41 @<:@default=no@:>@])],
+ enable_nfsv41=$enableval,
+ enable_nfsv41=no)
+ if test "$enable_nfsv41" = yes; then
+ AC_DEFINE(NFS41_SUPPORTED, 1, [Define this if you want NFSv41 support compiled in])
+ else
+ enable_nfsv4=
+ fi
+ AC_SUBST(enable_nfsv41)
+ AM_CONDITIONAL(CONFIG_NFSV41, [test "$enable_nfsv41" = "yes"])
+
AC_ARG_ENABLE(gss,
[AC_HELP_STRING([--enable-gss],
[enable support for rpcsec_gss @<:@default=yes@:>@])],