summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2095bdd..66d2a01 100644
--- a/configure.ac
+++ b/configure.ac
@@ -47,6 +47,10 @@ AC_SUBST(APXS2)
# We need the lasso library for SAML2 communication.
PKG_CHECK_MODULES(LASSO, lasso)
+saved_LIBS=$LIBS; LIBS="$LIBS $LASSO_LIBS";
+AC_CHECK_LIB(lasso, lasso_server_new_from_buffers,
+ LASSO_CFLAGS="$LASSO_CFLAGS -DHAVE_lasso_server_new_from_buffers")
+LIBS=$saved_LIBS;
AC_SUBST(LASSO_CFLAGS)
AC_SUBST(LASSO_LIBS)