summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorolavmrk <olavmrk@a716ebb1-153a-0410-b759-cfb97c6a1b53>2010-07-02 11:51:00 +0000
committerolavmrk <olavmrk@a716ebb1-153a-0410-b759-cfb97c6a1b53>2010-07-02 11:51:00 +0000
commit53b999c82f77366039cb4acc044242ffecb0393e (patch)
treeeafe73e1b9c10c0832f304400d1e228cdb03dbb6 /configure.ac
parent8196132f9d5a54c01e95198c0b726a0bf61ff98e (diff)
downloadmod_auth_mellon-53b999c82f77366039cb4acc044242ffecb0393e.tar.gz
mod_auth_mellon-53b999c82f77366039cb4acc044242ffecb0393e.tar.xz
mod_auth_mellon-53b999c82f77366039cb4acc044242ffecb0393e.zip
configure: Fix test for apxs.
git-svn-id: https://modmellon.googlecode.com/svn/trunk@103 a716ebb1-153a-0410-b759-cfb97c6a1b53
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 5 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index c7e3703..4eb8f4a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -9,24 +9,20 @@ AC_ARG_WITH(
[ --with-apxs2=PATH Full path to the apxs2 executable.],
[
APXS2=${withval}
- ],
- [
- APXS2='unknown'
- ]
-)
+ ],)
-if test "$APXS2" = 'unknown'; then
+if test "x$APXS2" = "x"; then
# The user didn't specify the --with-apxs2-option.
# Search for apxs2 in the specified directories
- AC_PATH_PROG(APXS2, apxs2, 'unknown',
+ AC_PATH_PROG(APXS2, apxs2,,
/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin)
- if test "$APXS2" = 'unknown'; then
+ if test "x$APXS2" = "x"; then
# Didn't find apxs2 in any of the specified directories.
# Search for apxs instead.
- AC_PATH_PROG(APXS2, apxs, 'unknown',
+ AC_PATH_PROG(APXS2, apxs,,
/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin)
fi