summaryrefslogtreecommitdiffstats
path: root/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAris Adamantiadis <aris@0xbadc0de.be>2011-01-13 18:34:04 +0100
committerAris Adamantiadis <aris@0xbadc0de.be>2011-01-13 18:34:04 +0100
commit2917e71aadae004f3a353c3de0672d7534e1a2bf (patch)
treede254390ede76ba980bb0a39a4f2abb42a69ee67 /tests/CMakeLists.txt
parent551b87b65b209255e60fbcaf146c43f2188ddc39 (diff)
downloadlibssh-2917e71aadae004f3a353c3de0672d7534e1a2bf.tar.gz
libssh-2917e71aadae004f3a353c3de0672d7534e1a2bf.tar.xz
libssh-2917e71aadae004f3a353c3de0672d7534e1a2bf.zip
Replaced argp support for platforms that support it
Argp is really useful, but it's not mandatory.
Diffstat (limited to 'tests/CMakeLists.txt')
-rw-r--r--tests/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/tests/CMakeLists.txt b/tests/CMakeLists.txt
index d5227b7..e620561 100644
--- a/tests/CMakeLists.txt
+++ b/tests/CMakeLists.txt
@@ -1,5 +1,7 @@
project(tests C)
+find_package(Argp)
+
set(TORTURE_LIBRARY torture)
include_directories(
@@ -14,13 +16,14 @@ include_directories(
)
# create test library
-add_library(${TORTURE_LIBRARY} STATIC torture.c)
+add_library(${TORTURE_LIBRARY} STATIC cmdline.c torture.c)
target_link_libraries(${TORTURE_LIBRARY}
${CMOCKERY_LIBRARY}
${LIBSSH_STATIC_LIBRARY}
${LIBSSH_LINK_LIBRARIES}
${LIBSSH_THREADS_STATIC_LIBRARY}
${LIBSSH_THREADS_LINK_LIBRARIES}
+ ${ARGP_LIBRARIES}
)
set(TEST_TARGET_LIBRARIES