summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2011-01-05 11:41:22 +0100
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2011-01-05 11:41:22 +0100
commit6c3684dc1f3acc49aec819f7594c3efbcac30173 (patch)
treeab0b9c42c5a792ede2ff0f164d18f4c7280ffae6 /Makefile.am
parent346071a6300032f17fcda345163bd5c444fb3c05 (diff)
downloadlasso-6c3684dc1f3acc49aec819f7594c3efbcac30173.tar.gz
lasso-6c3684dc1f3acc49aec819f7594c3efbcac30173.tar.xz
lasso-6c3684dc1f3acc49aec819f7594c3efbcac30173.zip
[dist] create Changelog directly from git
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index f700209d..3aecc4d5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,6 @@ MAINTAINERCLEANFILES = \
configure \
install-sh \
missing
-
pkgconfig_DATA = lasso.pc
pkgconfigdir = $(libdir)/pkgconfig
@@ -25,6 +24,17 @@ clean-local:
-rm -f lasso.pc
dist-hook:
- -rm -rf `find $(distdir) -name .svn`
+ @if test -d "$(srcdir)/.git"; \
+ then \
+ echo Creating ChangeLog && \
+ ( cd "$(top_srcdir)" && \
+ echo '# Generated by Makefile. Do not edit.'; echo; \
+ $(top_srcdir)/missing --run git log --stat ) > ChangeLog.tmp \
+ && mv -f ChangeLog.tmp $(distdir)/ChangeLog \
+ || ( rm -f ChangeLog.tmp ; \
+ echo Failed to generate ChangeLog >&2 ); \
+ else \
+ echo A git clone is required to generate a ChangeLog >&2; \
+ fi
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc