summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorBenjamin Dauvergne <bdauvergne@entrouvert.com>2013-05-15 11:28:25 +0200
committerBenjamin Dauvergne <bdauvergne@entrouvert.com>2013-05-15 11:28:25 +0200
commit57435048a01fe5bbe2a7c80d879e3c60c5c7785b (patch)
tree178caaffc9bb927018c0eb7235a751f502f410f2 /Makefile.am
parentaa43398da669f48653ce431763bd35264fd5e314 (diff)
downloadlasso-57435048a01fe5bbe2a7c80d879e3c60c5c7785b.tar.gz
lasso-57435048a01fe5bbe2a7c80d879e3c60c5c7785b.tar.xz
lasso-57435048a01fe5bbe2a7c80d879e3c60c5c7785b.zip
configure: generate version number from git revision between tagged release
The script git-version-gen is copied from the autoconf project.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 3aecc4d5..caca2f7d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,7 +7,9 @@ SUBDIRS = lasso \
docs
EXTRA_DIST = COPYING lasso.pc.in lasso-src-config.in autogen.sh tools abi \
- lasso.doap README.JAVA README.WIN32 HACKING logos
+ lasso.doap README.JAVA README.WIN32 HACKING logos $(top_srcdir)/.version
+
+BUILT_SOURCES = $(top_srcdir)/.version
MAINTAINERCLEANFILES = \
Makefile.in \
@@ -36,5 +38,9 @@ dist-hook:
else \
echo A git clone is required to generate a ChangeLog >&2; \
fi
+ echo $(VERSION) > $(distdir)/.tarball-version
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+
+$(top_srcdir)/.version:
+ echo $(VERSION) > $@-t && mv $@-t $@