summaryrefslogtreecommitdiffstats
path: root/src/configure.in
diff options
context:
space:
mode:
authorKen Raeburn <raeburn@mit.edu>2008-07-18 06:45:34 +0000
committerKen Raeburn <raeburn@mit.edu>2008-07-18 06:45:34 +0000
commit38c9c2df095e1ae4314f68e08966cd396c79e016 (patch)
treeaeee04baf8663864cf21b01b1b7400e9aeab5228 /src/configure.in
parent98895fc738671eed787e5049e69ffdd2b1f7ac91 (diff)
downloadkrb5-38c9c2df095e1ae4314f68e08966cd396c79e016.tar.gz
krb5-38c9c2df095e1ae4314f68e08966cd396c79e016.tar.xz
krb5-38c9c2df095e1ae4314f68e08966cd396c79e016.zip
On systems with struct rt_msghdr, open a routing socket and wait for
messages; when they come in, if the types suggest a possibility of network interface reconfiguration, shut down the KDC's networking and bring it back up again, rescanning the interfaces in the process. Leaving the ticket open because it should be improved: * It should only close down sockets on addresses we no longer have, and bring up sockets only on new addresses. * If we have IPV6_PKTINFO support, it should only listen for IPv4 routing changes. * If we also have IP_PKTINFO support, it shouldn't be used at all. * If we build a KDC on a system with neither struct rt_msghdr nor IP_PKTINFO (do we have any such?), we'll need another solution. Thanks to Nico Williams for the routing socket suggestion, and Apple for the initial (signal-driven) reconfiguration code. ticket: 6019 status: open git-svn-id: svn://anonsvn.mit.edu/krb5/trunk@20540 dc483132-0cff-0310-8789-dd5450dbe970
Diffstat (limited to 'src/configure.in')
-rw-r--r--src/configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/configure.in b/src/configure.in
index 362df0459..402e2516b 100644
--- a/src/configure.in
+++ b/src/configure.in
@@ -611,6 +611,11 @@ AC_CHECK_TYPES([struct cmsghdr, struct in_pktinfo, struct in6_pktinfo], , , [
#include <sys/socket.h>
#include <netinet/in.h>
])
+AC_CHECK_TYPES([struct rt_msghdr], , , [
+#include <sys/socket.h>
+#include <net/if.h>
+#include <net/route.h>
+])
dnl
dnl stuff for util/profile
dnl