summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-12-03 12:47:05 -0500
committerSimo Sorce <simo@redhat.com>2013-12-03 12:56:53 -0500
commit558499783511a0c04ca57827dd035126d940082d (patch)
tree58c9572f7347f1383355b3a451999f19106b7b69 /setup.py
downloadipsilon-558499783511a0c04ca57827dd035126d940082d.tar.gz
ipsilon-558499783511a0c04ca57827dd035126d940082d.tar.xz
ipsilon-558499783511a0c04ca57827dd035126d940082d.zip
Initial module
Signed-off-by: Simo Sorce <simo@redhat.com>
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 30 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100755
index 0000000..0e5f388
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,30 @@
+#!/usr/bin/python
+#
+# Copyright (C) 2013 Simo Sorce <simo@redhat.com>
+#
+# see file 'COPYING' for use and warranty information
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+from distutils.core import setup
+
+setup(
+ name = 'ipsilon',
+ version = '0.1',
+ license = 'GPLv3+',
+ packages = ['ipsilon'],
+ package_dir = {'ipsilon': 'src'},
+ data_files = [('share/man/man7', ["man/ipsilon.7"])],
+)
+