summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am19
1 files changed, 13 insertions, 6 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 9675aeb..1e7c39c 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -222,6 +222,13 @@ endif
#######################
dist_init_SCRIPTS =
+systemdunit_DATA =
+if HAVE_SYSTEMD_UNIT
+ systemdunit_DATA += \
+ systemd/gssproxy.service
+endif
+
+noinst_DATA = examples/gssproxy.conf examples/mech
edit_cmd = $(SED) \
-e 's|@sbindir[@]|$(sbindir)|g' \
@@ -242,12 +249,15 @@ EXTRA_DIST = \
examples/mech.in
systemd/gssproxy.service: systemd/gssproxy.service.in Makefile
+ @$(MKDIR_P) systemd/
$(replace_script)
examples/gssproxy.conf: examples/gssproxy.conf.in Makefile
+ @$(MKDIR_P) examples/
$(replace_script)
examples/mech: examples/mech.in Makefile
+ @$(MKDIR_P) examples/
$(replace_script)
installgsspdirs::
@@ -280,15 +290,12 @@ else
mkdir -p $(DESTDIR)$(initdir)
endif
-install-data-hook: systemd/gssproxy.service examples/mech examples/gssproxy.conf
-if HAVE_SYSTEMD_UNIT
- cp systemd/gssproxy.service $(DESTDIR)$(systemdunitdir)
-endif
-
clean-local:
rm -Rf doc
-CLEANFILES = *.X */*.X */*/*.X
+CLEANFILES = *.X */*.X */*/*.X \
+ examples/mech \
+ examples/gssproxy.conf
tests: all $(check_PROGRAMS)
$(srcdir)/tests/runtests.py