summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am38
1 files changed, 33 insertions, 5 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 4ba129d..9675aeb 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -23,6 +23,7 @@ localedir = @localedir@
ccpath = @ccpath@
initdir = @initdir@
systemdunitdir = @systemdunitdir@
+examplesdir= @datarootdir@/examples
logpath = @logpath@
pubconfpath = @pubconfpath@
pkgconfigdir = $(libdir)/pkgconfig
@@ -221,11 +222,33 @@ endif
#######################
dist_init_SCRIPTS =
-dist_systemdunit_DATA =
-if HAVE_SYSTEMD_UNIT
- dist_systemdunit_DATA += \
- systemd/gssproxy.service
-endif
+
+edit_cmd = $(SED) \
+ -e 's|@sbindir[@]|$(sbindir)|g' \
+ -e 's|@localstatedir[@]|$(localstatedir)|g' \
+ -e 's|@libdir[@]|$(libdir)|g' \
+ -e 's|@gpstatedir[@]|$(prefix)|g'
+
+replace_script = \
+ @rm -f $@ $@.tmp; \
+ srcdir=''; \
+ test -f ./$@.in || srcdir=$(srcdir)/; \
+ $(edit_cmd) $${srcdir}$@.in >$@.tmp; \
+ mv $@.tmp $@
+
+EXTRA_DIST = \
+ systemd/gssproxy.service.in \
+ examples/gssproxy.conf.in \
+ examples/mech.in
+
+systemd/gssproxy.service: systemd/gssproxy.service.in Makefile
+ $(replace_script)
+
+examples/gssproxy.conf: examples/gssproxy.conf.in Makefile
+ $(replace_script)
+
+examples/mech: examples/mech.in Makefile
+ $(replace_script)
installgsspdirs::
mkdir -p \
@@ -257,6 +280,11 @@ else
mkdir -p $(DESTDIR)$(initdir)
endif
+install-data-hook: systemd/gssproxy.service examples/mech examples/gssproxy.conf
+if HAVE_SYSTEMD_UNIT
+ cp systemd/gssproxy.service $(DESTDIR)$(systemdunitdir)
+endif
+
clean-local:
rm -Rf doc