summaryrefslogtreecommitdiffstats
path: root/proxy/configure.ac
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-11-20 11:58:22 -0500
committerGünther Deschner <gdeschner@redhat.com>2013-11-21 13:48:25 +0100
commit23f4ee4359d10f66e1938ce6b1d92d3cc77865ff (patch)
tree407122ce6e24f1a87d5a33d9b4e5dc3cea6b28fb /proxy/configure.ac
parenta272091dfd568cb96738cc96ea01bbf7f24ee62c (diff)
downloadgss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.tar.gz
gss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.tar.xz
gss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.zip
Use secure_getenv in client and mechglue module
proxymehc.so may be used in setuid binaries so follow best security practices and use secure_getenv() if available. Fallback to poorman emulation when secure_getenv() is not available. Resolves: https://fedorahosted.org/gss-proxy/ticket/110 Reviewed-by: Günther Deschner <gdeschner@redhat.com>
Diffstat (limited to 'proxy/configure.ac')
-rw-r--r--proxy/configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/proxy/configure.ac b/proxy/configure.ac
index b75a1ef..a0cc4ef 100644
--- a/proxy/configure.ac
+++ b/proxy/configure.ac
@@ -149,6 +149,8 @@ AC_CHECK_LIB(gssrpc, gssrpc_xdrmem_create,,
[$GSSAPI_LIBS $GSSRPC_LIBS])
AC_SUBST([GSSRPC_LIBS])
+AC_CHECK_FUNCS([__secure_getenv secure_getenv])
+
WITH_INITSCRIPT
if test x$initscript = xsystemd; then
WITH_SYSTEMD_UNIT_DIR