summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2013-11-20 11:58:22 -0500
committerGünther Deschner <gdeschner@redhat.com>2013-11-21 13:48:25 +0100
commit23f4ee4359d10f66e1938ce6b1d92d3cc77865ff (patch)
tree407122ce6e24f1a87d5a33d9b4e5dc3cea6b28fb /proxy/Makefile.am
parenta272091dfd568cb96738cc96ea01bbf7f24ee62c (diff)
downloadgss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.tar.gz
gss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.tar.xz
gss-proxy-23f4ee4359d10f66e1938ce6b1d92d3cc77865ff.zip
Use secure_getenv in client and mechglue module
proxymehc.so may be used in setuid binaries so follow best security practices and use secure_getenv() if available. Fallback to poorman emulation when secure_getenv() is not available. Resolves: https://fedorahosted.org/gss-proxy/ticket/110 Reviewed-by: Günther Deschner <gdeschner@redhat.com>
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index 065be6e..c946421 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -102,7 +102,9 @@ GP_RPCCLI_OBJ = \
src/client/gpm_wrap.c \
src/client/gpm_unwrap.c \
src/client/gpm_wrap_size_limit.c \
- src/client/gpm_common.c
+ src/client/gpm_common.c \
+ src/gp_util.c
+
GP_MECHGLUE_OBJ = \
src/mechglue/gpp_accept_sec_context.c \
src/mechglue/gpp_acquire_cred.c \
@@ -114,8 +116,7 @@ GP_MECHGLUE_OBJ = \
src/mechglue/gpp_indicate_mechs.c \
src/mechglue/gpp_priv_integ.c \
src/mechglue/gpp_misc.c \
- src/mechglue/gss_plugin.c \
- src/gp_util.c
+ src/mechglue/gss_plugin.c
dist_noinst_HEADERS = \
rpcgen/gp_rpc.h \