summaryrefslogtreecommitdiffstats
path: root/proxy/Makefile.am
diff options
context:
space:
mode:
authorSimo Sorce <simo@redhat.com>2012-08-08 10:57:53 -0400
committerSimo Sorce <simo@redhat.com>2012-10-25 15:53:30 -0400
commitd9e74f25520066db630bead29a0daa266acac2bf (patch)
tree855a4ba2481ab0d78b1e13732d63b443c644d7f6 /proxy/Makefile.am
parent76f4973f03e9149ee8040fa9a628e8470c23e5df (diff)
downloadgss-proxy-d9e74f25520066db630bead29a0daa266acac2bf.tar.gz
gss-proxy-d9e74f25520066db630bead29a0daa266acac2bf.tar.xz
gss-proxy-d9e74f25520066db630bead29a0daa266acac2bf.zip
New test program to exercise the mechglue plugin
Diffstat (limited to 'proxy/Makefile.am')
-rw-r--r--proxy/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/proxy/Makefile.am b/proxy/Makefile.am
index d6b1299..001e4e3 100644
--- a/proxy/Makefile.am
+++ b/proxy/Makefile.am
@@ -47,7 +47,7 @@ sbin_PROGRAMS = \
gssproxy
check_PROGRAMS = \
- cli_srv_comm
+ cli_srv_comm interposetest
gssplib_LTLIBRARIES = \
proxymech.la
@@ -176,17 +176,25 @@ cli_srv_comm_SOURCES = \
$(GP_RPCCLI_OBJ) \
tests/cli_srv_comm.c
+interposetest_SOURCES = \
+ src/gp_log.c \
+ src/gp_debug.c \
+ tests/interposetest.c
+
gssproxy_LDADD = \
$(GSS_PROXY_LIBS)
cli_srv_comm_LDADD = \
$(GSS_PROXY_LIBS)
+interposetest_LDADD = \
+ $(GSS_PROXY_LIBS)
+
dist_noinst_DATA += \
examples/gssproxy-example.conf \
m4
-noinst_PROGRAMS = cli_srv_comm
+noinst_PROGRAMS = cli_srv_comm interposetest
################
# TRANSLATIONS #